Xdebug always stops at start of file

I'm using xdebug to remotely debug a PHP application.

I made the mistake of leaving the "Force break at first line when no path mapping specified" the first time I attempted a debug.

Now even though I have the mappings applied, and have removed the tick to force the break at the first line - it still breaks every time.

This causes a problem as my mysql server is on a really short timeout, so half of my debug sessions lose their database connection before they hit my real breakpoint because I haven't hit continue fast enough. It also means i have to remove watches before each debug session - if they're not relevant to the landing script they can cause errors. It's generally making debugging impossible.

How can I stop it breaking on the first line? It's almost like there's a breakpoint created there after the first time - but one i can't remove. Anyone got any ideas that don't involve me wiping my project and starting again?

2 comments

Hi there,

Please check Run | Break at first line in PHP scripts

If it's already unchecked -- check (activate) it and uncheck again (sometimes ( WI-17389 ) it shows wrong status)

0

Thanks Andriy -- that was the problem.

One of the great things about PhpStorm is the number of features. One of the terrible things about PhpStorm is the number of features. :)

0

Please sign in to leave a comment.