SFTP upload hanging

Hi,

I'm currently using PhpStorm version 6.0.3.
Just today, my sftp uploads to my deployment server is not working. It just hangs saying "Uploading <filename>..."
This has been working for months and I've not changed anything. Though I must have since it's not working now. :-(

Here's what I've tried.
- Confirmed that I can sftp from my MacOS X command line using ssh keys
- Confirmed the ssh key password in Deployment is correct
- The "Test SFTP Connection" is successful
- I can click the button in the Mappings tab to browse the Deployment path on server 'name' and it successfully shows the remove files!
- Changed to username/password
- Edited the .idea/workspace.xml file and removed the <component name="PublishConfig"> element completely and reconfigured
a deployment server
- Insured all paths were correct
- Opened a different project with the same deployment server and it WORKED!

So the issue seems to be in the project somewhere. My only thought at this point is to delete the project and create a new
on with the existing files.

Note that the only way for me to stop the hanging sftp upload process in PhpStorm is to login to the remove server
and kill the /usr/libexec/openssh/sftp-server process. Oh, I also performed an strace on the sftp-server process and
it's not doing anything, like it's waiting for something to contact it.

Any help would be greatly appreciated. I'm loosing productivity every minute and I have a deadline to meet. Guess I'll
have to copy files over manually until I get this fixed. :-(

Thanks,
Rob

3 comments

Hi there,

You can check idea.log (Help | Show Log in Finder) for some hints (excpetion traces).

But since you need to resolve it rather quickly .. my comment will be not about actually fixing your issue (to find out why it happens; plus, I'm not a Mac user).

I suggest:

  1. Backup and delete your project configuration (PROJECT/.idea subfolder) while project is closed in IDE
  2. "File | Open Directory" (or "Open Directory" from Welcome screen) to open your project location
  3. Re-configure project from scratch.


Re-configuration (the most important parts of it) will take you just few minutes (plus, some of the config files can easily be restored from backup you made on #1) -- much faster than dealing with "copy files over manually".

When you will have time (and if you desire to do so) -- you can come back to it later (restore project config from backup and check what may be wrong).

0

Well cover me with jam and tie me to an ant hill!
After checking the logs and then trying to create a file on the remote host on the command line
showed that the filesystem was full! Doh!
Why we don't have a monitor in place for that is beyond me, but shame on me for not
checking that out first. Akin to "is it plugged in?"

Thanks for helping out.
Rob

1

2 hours spending to solve same "issue" by me

Thx for post the solution )

0

Please sign in to leave a comment.