Update Directory from CVS does not auto upload to deployment

(There was a post "Upload modified files only with FTP in PHPStorm?" in Feb 2012, but this did not answer my question, and the help text has shed no light either...)

I am an experienced phpstorm user and am very happy with the product.

There is one aspect of my daily routine that seems to be unnecessary:

1.  I use CVS > Update Directory to update my local source with the committed changes to the CVS made by other members in my team (no problems with this step)
2.  I have my deployment server options set correctly so my expectation is that the CVS changes made by other users (which have resulted in my local source being modified) will automatically be uploaded to my deployment server - but they are not.
3.  Instead I have to manually select Upload to <my deployment server> - which seems to copy ALL files and is very time-consuming - I want to avoid this step.

So my question:

1. Why is item 2 above not working? is this the expected behaviour?  Is item 3 really necessary?

Note 1: I do NOT wish to manually synch and compare as suggested in the help text, I simply want my default deployment server to automatically be kept up to date when I update from CVS.
Note 2: When I make changes to my local source, the changes are automatically updated to my deployment server so my configuration is working just fine (Deployment - Automatic Upload is set to Always).  It's other users' changes from CVS that are not being auto-uploaded.

My deployment option settings are:
PHP Deploy Options.jpg



Thank you.

4 comments

Hi there,

I'm not using any VCS and therefore cannot give you 100% accurate reply (in case I misunderstood you), .. but as far as I see it should be working already: http://youtrack.jetbrains.com/issue/WI-2171 (also because this ticket is asking for opposite behaviour: http://youtrack.jetbrains.com/issue/WI-16953 )
But, at the same time, that first ticket is still open .. so there still must be something to implement.

See if Synchronize button (or File | Synchronize) will do any good here (force rescan of local files).

Related:


BTW, the upload options seems to be OK.

0

Hi Andriy,

1.  That really does not answer the question at all. If you do not have VCS then you cannot test or address this issue.
2. I looked at the Issues you referenced in your post - from 3 years ago -  and I do not believe the issue has been addressed. Some user commented that this is one reason that he still uses Netbeans.
3. The Upload external changes setting checkbox is checked and should do exactly what I'm looking for but it does not work.
4. The synchronise option has nothing to do with this issue.

Please escalate this issue.

Thanks.

0
Some user commented that this is one reason that he still uses Netbeans.

That comment left on "21 Aug 2010 05:45".  Upload external changes checkbox has been added on "24 Jan 2011 10:20" (5 months later).

The Upload external changes setting checkbox is checked and should do exactly what I'm looking for

Did I said otherwise anywhere? I've confirmed that your settings are correct and it should work.

The synchronise option has nothing to do with this issue

Do you actully know what I'm talking about (File | Synchronize) and what it supposed to do? Where did I mention word "option" anywhere?

Two comments stated that upload did not started until IDE refreshed the list of project files -- "File | Synchronize" does exactly that. That's why I have suggested to try it in case IDE have not noticed those changes.

Please escalate this issue.

Cannot hep you -- I do not work for JB.


P.S.
I guess I should keep my mouth shut next time instead of trying to provide at least some help.

GL

0

Andriy -

1. My humble apologies - I DID think you worked for Jb .
2. I hope you can see that the tone of my message was one of frustration (at not being able to solve an issue I have had for a long time), rather than ingratitute.
3. I do very much appreciate your freely given help, and I followed your advice and checked out the Synchronize option - the update works (redface).

Certainly beats doing an Upload all  - thanks for your input.

I'll be more considered in my response next time :-)
Regards and keep up the good work,

Ed

0

Please sign in to leave a comment.