FTP: connection to 'example.com' failed [solved]

I'm unable to connect to a specific FTP server with PhpStorm. The message given upon clicking "Test FTP Connection..." is:

Connection to 'example.com' failed.
Could not login to FTP server on "example.com" as user "username".

I can successfully connect via other FTP applications using identical credentials, and I'm able to connect to other FTP servers with PhpStorm.

My log file is attached.



Attachment(s):
idea.log.zip
6 comments

Hi there,

So .. as I understand you do have an Deployment entry (Preferences | Deployment) with "example.com" as host name?

0

Thanks for the reply, Andriy.

I changed the hostname to protect my client's privacy. (I don't like to post details like this on a public forum.) I'm happy to share it privately if it would help.

0

I see.

Well ... the error says that the login details provided were incorrect -- nothing more that that (no other details/hints in the log you have provided). Right now I can only suggest double (triple) checking your login details again -- maybe you did not provided password / wrong password; correct user name; check spelling of host name (if domain name is used); try IP address instead.

0

Whats the 'other FTP application'?

Because if its filezilla then sometimes those type of make it easy applications do a lot of extra figuring out for you.

I usually use konqueror and sometimes it will fail where filezilla will work because the of extra figure-it-out logic in the program.

If i can connect with konqueror to:
location: ftp://example.com
username: bob
password: 123456

Then those credentials will also work in phpstorm.

But sometimes those will fail and ill go to filezilla to get it to figure it out for me.

sometimes its:
location: ftp://ftp.example.com
username: bob
password: 123456

OR
location: ftp://example.com
username: bob@example.com
password: 123456

Are some variations i've seen before.

OH, and sometimes its a different FTP port:
location: ftp://example.com:2121
username: bob
password: 123456

0

Aha! I triple-checked the credentials and found that the Mac Keychain Access app had reported the password incorrectly. Retyped it manually and PhpStorm connects first time. Sorry for the trouble!

0

Thanks, Michael. You were right – it was a simple misconfiguration problem on my part.

0

Please sign in to leave a comment.