Strange 'caret' behavior in Webstorm editor

I just started using Webstorm and I can't figure out how to fix this bug.
Say if I'm editing an HTML file in Webstorm and I click on the whitespace to the right of a tag in any given line. My caret is supposed to appear right next to the tag, and NOT where I actually clicked.
Editing HTML files in PyCharm does this correctly.
To illustrate (consider '_' as blank space, and 'V' where I clicked, and '|' where the caret appears).
<html>_________________________________________V_______________________________
in WebStorm, Caret appears here:

<html>_________________________________________|_______________________________
Whereas the expected behavior would be for it to appear here (which PyCharm does well):

<html>|_________________________________________________________________________



Is there a way to fix this in the settings?
1 comment

Hi there,

Settings | Editor | Allow placement of caret after end of line

P.S.
Settings screen has search box (top left corner) -- if you type some keyword(s) (e.g. "caret") it will show you all settings that have it in their names, which will help you finding correct settings quicker.

0

Please sign in to leave a comment.