using weblogic ant tasks with intellij

hi all,

i'm trying to use a weblogic ant task from wls 8.1 in an intellij project. i have the correct jars in my project classpath, and in my ant classpath, and intellij still cant find the ant tasks? has anyone come across this?

~jeff

4 comments
Comment actions Permalink

i'm trying to use a weblogic ant task from wls 8.1 in an intellij project.

i have the correct jars in my project classpath, and in my ant classpath,
and intellij still cant find the ant tasks? has anyone come across this?

Did you add the Ant build file in the Ant Build toolwindow ?
Then, did you click on the button representing little checkboxes to view the
Build File Properties dialog window ?
And finally, in the "Additional Classpath", did you add the jar file in the
list ? or did you try the "include project classpath" checkbox ?

Hope it helps.

Guillaume Laforge


0
Comment actions Permalink

hi guillaume,

i have the tasks in my ant window, i have added the jars to my additional classpath, and i have included the project classpath where the jars also reside. it still doesn't pick up the custom ant tasks. any suggestions?

~jeff

0
Comment actions Permalink

i got it to work, here's what i did. ( by the way, i'm using intellij 3.0.2 build #696 and weblogic 8.1)

the build.xml i was trying to use was one from the webservice examples in weblogic. the build files use custom tasks, but some don't have to declare taskdefs to use them.

when i noticed this, i wrote the taskdefs, but intellij still didnt recognize the custom tasks when called in a target.

        • solution:

to get intellij to recognize the custom tasks, i had to declare all the taskdefs, and restart intellij.
****

only after i restarted did it pick up the custom tasks. weird, huh?

thanks,
~jeff

0
Comment actions Permalink

i have the tasks in my ant window, i have added the jars to my additional

classpath, and i have included the project classpath where the jars also
reside. it still doesn't pick up the custom ant tasks. any suggestions?

Hmmm... well...
One last suggestion, dunno whether it'd change something or not, but did you
try to run Ant with a custom JDK ?
It's in the Build File Properties dialog window, click on the Execution
panel, and there's a checkbox there.
Otherwise, I don't know what's wrong there :(

Guillaume


0

Please sign in to leave a comment.