Remote javascript debugging doesn't work [Solved]

i follow this tutorial step by step
http://www.jetbrains.com/phpstorm/webhelp/debugging-javascript.html

and then get this in phpstorm:
Selection_100.jpg
also firefox is waiting
Selection_101.jpg
and doesn't show anything to something happen in phpstorm but as you can see all debug buttons disabled.

so i don't get this page in last step (from that toturial)
http://wiki.jetbrains.net/i/images/5/55/Ws_debug_tool_window.png
nothing happend until i press the first button in debug column (rerun)
script finished and no stopping or debuging in breakpoints

any idea ?

(i'm gonig to try local debuging)

18 comments

well local is worked correclty
but the question is
if i have php project on my localhost and it made with both of javascript and php then could i debug my javascript specially Ajax on local javascript debug mod ?

0

hi dude

i faced to problem in first article and seccond works correctly

i got new something from remote javascript debug and it is i got this message in console:

Use of Mutation Events is deprecated. Use MutationObserver instead. chrome://firebug/content/chrome/tabContext.js:589

0

i guess something i got two message in console also in script tab that they are not related to my script :

Selection_102.jpg
and in scripts tab i see a script that i don't have it in my files:
Selection_103.jpg
also i don't have no cookie related to phpstorm in my browser cookies:
Selection_104.jpg

0
i faced to problem in first article and seccond works correctly

Please show you run/debug configuration details. Simple test project is also very welcome.

i got new something from remote javascript debug and it is i got this message in console:

Use of Mutation Events is deprecated. Use MutationObserver instead. chrome://firebug/content/chrome/tabContext.js:589

This message/error comes from one of the firebug files (as file path suggests).

P.S.
You can alsways try Chrome browser instead of Firefox -- it is pretty much the same.

0

Hello!

this message has nothing to do with PHPStorm - this is Firebug issue. You must have the "Show Chrome Messages" or/and the "Show Chrome Errors" options enabled.
Please, provide the screenshot of the run configuration you are using for remote debugging


Best regards,
Lena

0

oooh it start again palying with me

this is very intersting thing
another page that has javascript active phpstorm and it is going to debug them without any breakpoint....
but inside project folder nothing happend (This same happeing when i wanted to debug php files with xdebug)

so now what logs should i post ?

it's my config:
Selection_106.jpg
php storm 6.0.2 build 129.394

$ java -version
java version "1.7.0_21"
Java(TM) SE Runtime Environment (build 1.7.0_21-b11)
Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)


but it worked in chrome
but i have another problem now
it's going step to but i cant undrestand which line is now work
just some information change in variable

and i press step into nothing appear on chrome :
Selection_107.jpg
Selection_108.jpg
0

So .. you have made a mapping for a single file (yes, a file) .... and expect this to propagate to other files (e.g. into numbers.js)? If so -- then I'm afraid you are wrong (it does not work this way, unfortunately) -- file is a file -- it does not affect other files (even if they are next to it).

Instead you should make mapping for the folder (e.g. PROJECT/tests == http://support.saze90.com/tests/) -- in such case all files/folders in this folder will inherit mapping from parrent folder (e.g. PROJECT/tests/javascript_debug/numbers.js would == http://support.saze90.com/tests/javascript_debug/numbers.js automatically)

Right now you have only one .html file mapped. IDE does not know how number.js is mapped so cannot stop on those breakpoints.

0

i changed to everything you said:
Selection_109.jpg
but it doean't change result
i also add variable i to watch but i can see printe the string with each step into or print number for i in variables tab (just like that toturial) soem un undrestable information changes in bottom

0

i changed to everything you said:
but it doean't change result

Please provide some standalone simple project that can be used for testing (2-3 files should be just fine). I guess contents of PROJECT/tests/javascript_debug/ should be fine.

i also add variable i to watch but i can see printe the string with each step into or print number for i in variables tab (just like that toturial) soem un undrestable information changes in bottom

Sorry, but I do not understand what you are trying to say here.

0

my apologizes
you are right
i typed fast and not recheck again
i wanted to write :
i also add variable i to watch window but i can't see printe the string in each step into (press F5 button) or print number for i in variables tab (just like that toturial)
http://wiki.jetbrains.net/i/images/5/55/Ws_debug_tool_window.png
http://wiki.jetbrains.net/i/images/3/31/Ws_remote_debugging_intermediate_result.png
just provides some Incomprehensible information in variables window

also i just use example and codes from that tutorial

numbers.js=
var i=0;
 for (i=0;i<=10;i++)
  {if (i==3)
    {
    continue;
    }
  document.write("The number is " + i);
  document.write("<br/>");
 }
numbers.html=
import that source 
0

i also add variable i to watch window but i can't see printe the string in each step into (press F5 button) or print number for i in variables tab (just like that toturial)

I still do not understand what you are trying to say here. I guess it is about variables (you still cannot see them).

Well -- this works just fine here, in both Chrome and Firefox:

screen01.png

screen02.png

You can check this test project -- it should have all what is required already configured (it uses built-in HTTP server that can serve static files, no need to copy anything anywhere, just extract as is and use it)



Attachment(s):
abcd.7z.zip
0

thanks for your response
i exctract it and but i don't get 404 Not found error on both firefox and chrome

the settings seems corret :
Selection_166.jpeg
Selection_167.jpeg
Selection_168.jpeg
Selection_169.jpeg

0

What is your IDE and version exactly (Help | About) ? It has to be PhpStorm v6.0.1 (build 126.339 or newer -- http://youtrack.jetbrains.com/issue/WI-17044 ) or WebSorm v6.

Built-in server details: http://blog.jetbrains.com/webstorm/2013/03/built-in-server-in-webstorm-6/

  • Possibly the internal http server is either sitting on different port (for whatever reason) or even simply unavailable (for unknown for me reason). Check what ports IDE is listening on (use your software firewall .. or netstat command to see what programs use what ports).
  • Or maybe you have renamed the project or project folder? The URL is dynamic and must match the project name.


In any case: you can upload those files to your own server and adjust URLs in Run/Debug Configurations as required

0

yes in new version worked
i'm going to investigate your config
thanks anyway

0

ok solved
now works great
but one more question how do you enable remote window ? on my project i don't find this dialog (that pluging is enabled also)

0

in your project there is remote host window in rigth side that i found that
it will be enable in this menu : Tools >  Deployment > Browse remote host

thanks again
this problem solved

0

Please sign in to leave a comment.