Darcula Theme Colors & Fonts Question

Hi, I recently switched over to Darcula theme and noticed that when I use browser prefixes in CSS files that line is highlighted with a color indicating the property doesn't exist according to the W3C.

Is it possible to alter the color / transparency of that highlighted indicator with the Colors & Fonts settings or via any other configuration?

Thanks,
Matt

8 comments
Comment actions Permalink

Hi Matt,

There is no "transparency" setting for fonts/colors in IDE.

But any colors used in Editor area can be configured via "Settings (Preferences on Mac) | Editor | Colors & Fonts" -- you just need to find the right style to edit.

If you can provide some sample CSS (to copy-paste) and screenshot with what you see there, I may help you finding the right style (in case you will have troubles finding it yourself; some inspections can be tuned to ignore some "errors").

0
Comment actions Permalink

Hi Andriy,

Thanks for the quick reply.

I think the style I am wanting to edit would be a 'warning' or 'syntax error' style for the following css code:

    border-bottom-left-radius: 4px;
    border-bottom-right-radius: 4px;
    -moz-border-radius-bottomleft: 4px;
    -moz-border-radius-bottomright: 4px;
    -webkit-border-bottom-left-radius: 4px;
    -webkit-border-bottom-right-radius: 4px;

all of the moz and webkit browser specific styles are highlighted or have a very light background color.

Thanks!

Matt

p.s. I attached a picture to better indicate what I'm talking about ... I'm using the Darcula theme with some style modifications to php files.



Attachment(s):
CssHighlightingPhpStorm6_0_1.png
0
Comment actions Permalink

Hi Matthew,

As I understand you see this "warning"
screen01.png
If so -- this 3rd party library: W3C inspection ( http://jigsaw.w3.org/css-validator/ )

You can either disable it completely .. or just tell it to NOT to treat vendor specific properties as errors: "Settings | Inspections | CSS | W3C CSS Validator" (PhpStorm/WebStorm must be v6.0.1 or newer)

P.S.
The "warning" color can be configured at "Settings | Editor | Color & Fonts | General | Warning"

0
Comment actions Permalink

Thanks Andriy!

Thats exactly what I was looking for.

Take care!

Matt

0
Comment actions Permalink

White tabs - it's awful. How to change?

0
Comment actions Permalink

Hi there,

Unfortunately I have no clue what you are talking about. Please explain in details (with screenshots).


BTW, you should have created your own thread as your issue may be completely different to what Matthew had.

0
Comment actions Permalink

I think this thread is well suited to discuss the theme Dracula



Attachment(s):
Безымянный.png
0
Comment actions Permalink

It looks like you face the issue http://youtrack.jetbrains.com/issue/IDEA-104684
It is already fixed and the fix will be available soon.

0

Please sign in to leave a comment.