[OS X] Disable pinch to zoom?

Is there any way to disable the pinch to zoom functionality in PhpStorm? I use it a lot on my MBP with the builtin trackpad, and I use it for scrolling. Nearly every time I try to scroll though, it detects it as a pinch and changes the text size, which is very annoying. Is there any way to disable this? I never need to change my text size anyway, I don't mind not being able to.

Thanks,
Matt

2 comments

Hi Matt,

I'm not Mac user and not sure of this one will help, but please try "Preferences | Editor | Change font size (Zoom) with Ctrl+Mouse Wheel" -- it may control it as well.

0

That might not work. The pitch-to-zoom is a system wide key. I usually end up just turning it off completly. BUT you could write a script (in applescript, ruby or pyhton, etc) that would toggle said key when PHPstorm runs/exits.

Something to think about. ;)

0

Please sign in to leave a comment.