WebApp-Run/Debug and JARs in WEB-INF/lib (WinXP)

I have a web-app with some JARs in WEB-INF/lib. I put them there for using the web-app run/debug feature. While running the web-app, the JARs are blocked (i.e. I cannot delete or update them) which ist fine since the server needs them. Usually after stopping the server the JARs are freed (i.e. I can delete or update them), but sometimes the JARs remain blocked and I cannot update them for the next run. Is there any known reason for the JARs remaining blocked sometimes after stopping the web-app?

Michael

1 comment
Comment actions Permalink

One of the possible reasons is that server's java process is still in memory
(the process was not terminated properly). Please check this in the task
manager.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


"Michael Descher" <michael.descher@gmx.de> wrote in message
news:1106834.1038174518440.JavaMail.jrun@is.intellij.net...

I have a web-app with some JARs in WEB-INF/lib. I put them there for using

the web-app run/debug feature. While running the web-app, the JARs are
blocked (i.e. I cannot delete or update them) which ist fine since the
server needs them. Usually after stopping the server the JARs are freed
(i.e. I can delete or update them), but sometimes the JARs remain blocked
and I cannot update them for the next run. Is there any known reason for the
JARs remaining blocked sometimes after stopping the web-app?
>

Michael

>


0

Please sign in to leave a comment.