Background color External libraries

Hello,

I've added Zend Framework to the external libraries path, and the background turned blue... with black characters... Not quite readable. Can I change this? Changing the theme does not effect it.



Attachment(s):
Naamloos.png
6 comments

Hi Marcel,

If I copy some file from External Library into actual project .. I see no difference between them in terms of color highlighting -- the only difference I see is that no inspections are run for External Library file.

project file
screen01.png
external library file
screen02.png

P.S.
Background can be configured at "Settings | Editor | Colors & Fonts | PHP | PHP Code" for PHP only or at "Settings | Editor | Colors & Fonts | Language Defaults | Template language" for ALL template languages

0

Thank you for your response, but it's not about syntax highlighting, its about de background color for external libraries in the project pane, as shown in the attached screenshot :-)

0

Settings | File Colors | Use in Project View


I think mentioning "Project View/Panel" in original question would help a lot: the only "blue" backgound I see is in syntax colors (PHP code background -- light blue) -- there is no way for me to make relation between "blue" and background of files in Project View -- those colors are nowhere near each other.

0

Thinks its confusion caused by my lack of proper English, and being new to PHPStorm, not knowing its official name. And my monitors renders it dark blue... nearly dark purple or black.

Anyway, the problem is that filenames are not readable, you must aggree on that :) So my original intented question; how to change that background color?

0
So my original intented question; how to change that background color?

Settings | File Colors

Either change that color there to more suitable .. or untick "Use in Project View" so it will only be used in Tabs

P.S.
I do agree on confusion part -- I should have paid more attention to words "file names" instead of concentrating on words "blue" and "background".

0

Ah, found it, changed it. Thanks!


0

Please sign in to leave a comment.