Type quotes without space, setting?

Answered

I have a problem, right now inside PhpStorm whenever I type a single or double quote I have to hit the spacebar to get the character to appear, if I would type a letter it applies it to the character like an international keyboard setup would (i.e. typing singlequote-a becomes á, typing doublequote-o becomes ö)
And before you say it must be the Windows settings, no it's not, this only happens inside PhpStorm, not in any other program (I really hate that behaviour so it's always off on my computers).

I might have changed a setting by hitting the wrong keyboard shortcut but I can't seem to figure out how to change it back.

I've gone over the settings from every angle I can think of and gone through the default keymap list but I can't find how this happened (and I'm pretty sure it didn't happen until a day or two ago). Can anyone please help me out because this is even more annoying inside a IDE where you use quotes all the time, than outside of it.

2 comments

Never mind, it turns out someone using my computer switched it to US international after all, which strangely didn't affect
my browser but did affect PhpStorm and Thunderbird.. problem solved.

2

Same for me, on my Mac I had the US International keyboard layout, and I had same behaviour with phpStorm... after i set the simple US keyboard layout from Mac settings/Keyboard all come back to normal.

2

Please sign in to leave a comment.