WebServer Cannot bind to our default range

I've installed WebStorm 6.0.1 and Chrome Version 26.0.1410.43  on Windows 7 64bit, with the latest Chrome IDE Support Extension (0.5.9).

The problem is that I cannot get WebStorm and Chrome to communicate (Live Edit/Debugging) unless I change Chrome extension's port each time I run WebStorm to match what WS is using.  Here's a typical WS log:

2013-04-03 14:49:27,728 [   5850]   INFO -    #org.jetbrains.io.WebServer - We cannot bind to our default range, so, try to bind to any free port
2013-04-03 14:49:27,729 [   5851]   INFO - jetbrains.ide.WebServerManager - web server started, port 4952

That port is different each time I run. If I try to debug, I get "Please ensure that JetBrains IDE Support extension is installed and enabled in Google Chrome", and "Waiting for a connection from JetBrains IDE Support Extension for Chrome. Please ensure you have installed the extension or see Help".

But there are two work-arounds: First, if I open the log, see what port it is using this run, go into the Chrome Extension's Options and set the port to match, then all is well until the next run, when a different port will be selected.
The better word-around is to edit <programfiles>\JetBrains\WebStorm 6.0.1\bin\webstorm.exe.vm, and add

-Drpc.port=<some port>

And set the Chrome side of things (JetBrains IDE Support Extension/Options/Port) to the same number.

And now I don't have any problems. But I'm posting this with all the error messages I saw in case there's someone else in this situation.

But maybe there's a real fix I could do?

Things I've tried:

  • restarting
  • checking netstat for something sitting on the default port
  • disabling my firewall


Thanks for any help
jh

Please sign in to leave a comment.