6 comments
Comment actions Permalink

Arif,

Add Web Application to your project and go to Run options - you'll be able
to define WebApp target.

--
Best regards,
Mike Aizatsky.
-


JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


0
Comment actions Permalink

Thanks Mike but I don't see any define WebApp target option? I already had a
Web App defined, I deleted and then re-added it but still I don't see
anything.

Thanks for your help,

Arif

"Mike Aizatsky" <mike@intellij.com> wrote in message
news:ahmpi8$5kd$1@is.intellij.net...

Arif,

>

Add Web Application to your project and go to Run options - you'll be able
to define WebApp target.

>

--
Best regards,
Mike Aizatsky.
------------------------------
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"

>
>


0
Comment actions Permalink

Same here, web application configured but no ability to define a web
app target.

Michael

On Wed, 24 Jul 2002 11:07:24 -0700, "Arif Butt" <abutt@prenet.net>
wrote:

>Thanks Mike but I don't see any define WebApp target option? I already had a
>Web App defined, I deleted and then re-added it but still I don't see
>anything.
>
>Thanks for your help,
>
>Arif
>
>"Mike Aizatsky" <mike@intellij.com> wrote in message
>news:ahmpi8$5kd$1@is.intellij.net...
>> Arif,
>>
>> Add Web Application to your project and go to Run options - you'll be able
>> to define WebApp target.
>>
>> --
>> Best regards,
>> Mike Aizatsky.
>> -


>> JetBrains, Inc / IntelliJ Software
>> http://www.intellij.com
>> "Develop with pleasure!"
>>
>>
>

0
Comment actions Permalink

The only new option i see in there is "Context path". I believe this is
supposed to be the path used to access the webapp from the URL, and in my
case it's / in Tomcat, so I set it to / in IDEA.

Breakpoints stilll don't work.

Does it have anything to do with the Working directory, the server.xml, or
any tomcat settings?

Ian.




"Mike Aizatsky" <mike@intellij.com> wrote in message
news:ahmpi8$5kd$1@is.intellij.net...

Arif,

>

Add Web Application to your project and go to Run options - you'll be able
to define WebApp target.

>

--
Best regards,
Mike Aizatsky.
------------------------------
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"

>
>


0
Comment actions Permalink

Also, does it have to do with the location of the compiled .jsp files?

Mine are in: DEBUGGER_WORKING_DIR\work\Standalone\localhost\_

And the naming convention generally maps like this:
SpecEdit.jsp -> SpecEdit$jsp.java
CqtLoginContent.jsp -> CqtLogin_0005fcontent$jsp.java
clnt_org.jsp -> clnt_0005forg$jsp.java
clnt_order_confirm.jsp -> clnt_0005forder_0005fconfirm$jsp.java

Ian.


"Ian Zabel" <izabel@cirqit.com> wrote in message
news:ahn2lt$fb3$1@is.intellij.net...

The only new option i see in there is "Context path". I believe this is
supposed to be the path used to access the webapp from the URL, and in my
case it's / in Tomcat, so I set it to / in IDEA.

>

Breakpoints stilll don't work.

>

Does it have anything to do with the Working directory, the server.xml, or
any tomcat settings?

>

Ian.

>
>
>
>

"Mike Aizatsky" <mike@intellij.com> wrote in message
news:ahmpi8$5kd$1@is.intellij.net...

Arif,

>

Add Web Application to your project and go to Run options - you'll be

able

to define WebApp target.

>

--
Best regards,
Mike Aizatsky.
------------------------------
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"

>
>

>
>


0
Comment actions Permalink

Hello,

By a mistake, JSP debugging wasn't enabled in build #637. It will be enabled
in build #638.

--
Best regards,
Mike Aizatsky.
-


JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


0

Please sign in to leave a comment.