WebStorm autosaves SCSS-files instantly

Hi.  I have WebStorm 6.0 build #WS-127.68 on a Win7 machine. The problem is that it autosaves the edited file immediately after each keypress. The delay is no more than one second. The problem is made worse because I have a SCSS file watcher. After each keypress I get the Executing 'SCSS' task -message. And as it tries to compile SCSS into CSS in the middle of the editing the error console also opens complaining about invalid SCSS code.

In settings I have set "Save files automatically if application is idle for 600 s". How do I solve this problem?  IB



Attachment(s):
WebStorm autosave.png
2 comments
  1. Settings | File Watchers
  2. Find your entry for SCSS files
  3. Untick "Immediate file synchronization"


P.S.
Laso check if you have Live Edit enabled (not just a plugin, but the actual functionality: View | Live Edit) as they may conflict with each other: http://youtrack.jetbrains.com/issue/WEB-7030

0

That did the trick. Thank You for the quick reply. IB

0

Please sign in to leave a comment.