1 comment
Comment actions Permalink

I'm having the exact same problem. I disabled the "sourcepath" like you
suggested. This is now compiling fine but only the remote interface shows
off in the EJB panel. This problem renders the EJB integration totally
useless.



I noticed that when the "sourcepath" is enabled, the project panel contains
both the root project and the EJB project. Is it the correct behavior?



Here is a project that reproduces this problem. I did not include the
j2ee.jar file to reduce the size of the archive as much as possible.



Manuel

"Mike Aizatsky" <mike@intellij.com> wrote in message
news:ad5q94$9fd$1@is.intellij.net...

Bill,

>

It seems that your ejb configurations have additional source paths turned

on

(see Project properties). Try to turn off "sourcepath" checks.

>

PS Could you please be so kind to post all j2ee-related issues to eap.j2ee
newsgroup?

>

--
Best regards,
Mike Aizatsky.
------------------------------
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"

>
>

"Bill Pfeiffer" <pfeiffer@gte.net> wrote in message
news:ad5q3p$9c1$1@is.intellij.net...

As i have not seen a good answer to this yet, I am going to post it

again.

I am maintaining a j2ee project. I have all my source under a single

source

tree. When I go to debug within Idea 626, it tries to compile

everything

and gets tons of "duplicate class errors". If I turn off the "EJB"

feature

in Idea 626, the pre-compile before debug goes just fine. It looks like
using the EJB managaement feature of Idea somehow causes this duplicate
class error.

>

Is there a fix on the horizon or is this just how it works (or doesn't

work

as the case may be...)?

>

Bill Pfeiffer

>
>

>
>






0

Please sign in to leave a comment.