Composer on mapped network drive

I have all my php projects stored on a shared network drive, mappen in windows to R:\
I want to use Composer-support from inside PhpStorm 6. The Init goes as it should. A composer.json is generated, I fill in the details and save the file.

But, when I want to add a dependency, using the gui, I see that phpstorm runs this command:

php.exe "C:\Program Files (x86)\PHP\Composer\composer.phar" require zendframework/zendframework:2.1.4 -n --no-progress

This gives the error 'composer.json is not writeable'. Why is this? What can I do to solve it? I mean, the file can be edited and saved from inside phpstorm and any other editor I use, so why does php think it is not writeable?

Did you try to run the same command from terminal? Could there be a network connection problem when you tried?


I tried the same command from the commandline, when placed in the networkdrive. The same error there. Running the command on a local drive gave no errors, that just installed the package.

Checking the permissions on the file, it seemed like my user had all the permissions needed. However, when I also gave write-permissions on the file to everyone (when right-clicking the file -> properties -> security) it worked. Also from inside phpstorm.


Working folder is project root, which is on mapped drive in your case.  Working with projects on network drives is highly not recommended as IDEA-based products relly on fast access to project files. You can use Create project from existing sources to copy the code locally and then autoupload all changes to the mapped drive.


I've been running with my projects files on a mapped network drive for years, thats not going to change. The speed is not a problem for me. Only problem is that the php executable seems to have som other rights on the files than phpstorm has. Even though running as the same user.

But this is more of a windows problem than one of phpstorm.


Please sign in to leave a comment.