Force editor to display as specified code format?

Hey all. I'm working inside of a coworkers php "framework" and he builds the body of the HTML for a view in a GIANT<<< EOT. This makes php storm highlight it as a string and not do any formatting/highlighting/autocompletion on the HTML. Is there a comment flag or feature that might make PHP Storm see this as HTML? Any solutions welcome. Thanks!

2 comments

Hi Stephen,

I'm not 100% sure what exactly you are about .. but I guess you are after Language Injection: put cursor in such string, Alt+Enter -> Inject Language

If my guess is wrong -- please provide some additional details: examples/screenshots.

0

Yes! Thanks so much. Language injections were exactly the ticket.

0

Please sign in to leave a comment.