PhpStorm and PHPUnit, wrong include path

I am trying to get PHPUnit to work with PhpStorm 5.0.

The problem is that when I try running a test, I get the following error:

---------------------

E:\wamp\bin\php\php5.3.13\php.exe C:\Users\Cristian\AppData\Local\Temp\ide-phpunit.php --no-configuration StackTest E:\wamp\www\renting\tests\StackTest.php
Testing started at 01:49 ...

SCREAM:  Error suppression ignored for
Warning: require_once(PHPUnit/Runner/Version.php): failed to open stream: No such file or directory in C:\Users\Cristian\AppData\Local\Temp\ide-phpunit.php on line 166

Call Stack:
    0.0030     817624   1. {main}() C:\Users\Cristian\AppData\Local\Temp\ide-phpunit.php:0
    0.0041     817624   2. IDE_PHPUnit_Loader::detectPHPUnitVersionId() C:\Users\Cristian\AppData\Local\Temp\ide-phpunit.php:3


---------------------

I don't understand why it is going to the C:\ directory when I have everything, including my include path, in E:\.

Any ideas?
1 comment

Solved it!

It seems that there was a problem with some dependency, specifically pear.symfony.com/Yaml.

Solved it by doing:
pear channel-discover pear.symfony.com
pear install pear.symfony.com/Yaml
pear install --alldeps pear.phpunit.de/PHPUnit

0

Please sign in to leave a comment.