disabling slash placement at the begining of line in line comment

Hi there,

When i comment a line with shortcut ctrl+/ , the two slashes are placed at the begining of the line wich is not PS2 compliant. See the example bellow :
Prise le 01/03/2013, a 11:31:03
How i can set the placement to be juste before the first letter of my code?

3 comments
Comment actions Permalink

Hi Emmanuel,

AFAIK you cannot, unless typing them manually instead of using "Comment Line" action.

For PHP it always inserts it as first character in line. On another hand for XML (for example) it surrounds each tag omitting any space around the tags.

I think I saw a ticket for such request .. but cannot find it right now. Maybe you can be more lucky. If not -- feel free to file new Feature Request ticket to the Issue Tracker

P.S.
There is an option at "Settings | Code Style | PHP | Wrapping and Braces | Keep when reformatting | Comment at first column" .. but that is a bit different -- it does not seem to affect "Comment Line" action in any way (works only during code reformat)

0
Comment actions Permalink

Ok thanks for your answer :)

0
Comment actions Permalink

This is a ticket WI-14262.

Emmanuel, feel free to vote for this issue.

0

Please sign in to leave a comment.