jQuery as a library - problem

Hi!

I'm using PhpStorm EAP 110.437 now.

I try to install jQuery 1.7.0 as a Library in my project. I use JavaScript Libraries module in Settings. When I use predefined jQuery 1.6.2, everything is OK. But when I try to install jQuery 1.7.0, I don't get any results...

First I downloaded the jquery.min.js file, and saved it in my [Project]/sys/ folder. Then I went to Settings/JavaScript Libraries and clicked Add. I entered a name "jQuery-1.7.0", chose framework type as jQuery, entered 1.7.0 as version, and attached my file: [Project]/sys/ - It is automatically set as Release. Next, I clicked Specify and clicked OK when the prompt suggested "http://api.jquery.com" as a doc link, and then clicked Download, so I got API for jQuery downloaded. Next I clicked OK and my new library jumped onto libraries list as type Global.
The next step was to go to Settings/JavaScript Libraries/Usage Scope and make sure that jQuery-1.7.0 is checked as one of default libraries for whole project. Finally I closed settings by clicking OK, and...

... and in my jQuery code, there are still methods underlined as problems, and when I point at the methods I get a tooltip with message: "Unresolved function or method...". And I still can't use code completion etc.

What do I do wrong? :\



Attachment(s):
jquery-lib.JPG
8 comments
Comment actions Permalink

Adam,
can you please provide any examples?

0
Comment actions Permalink

Hello, Rustam.

I think the simpliest way to show the problem is to attach few pictures of my config and situation in code:

1. I added jQuery-1.7.0 to my JS Libraries:

jquery-lib1.JPG

2. This is how I configured the lib:

jquery-lib2.JPG

3. Next I put the lib as a default for the whole project:

jquery-lib3.JPG


4. But even now, I can't use either autocomplete nor documentation in my code (note the underlined symbols...):

jquery-lib4.JPG

because standard jQuery methods are not known to IDE:

jquery-lib5.JPG

Is this some kind of problem with PhpStorm, or maybe I am the problem? :(

Any help would be appreciated.

Thanks.
Adam

0
Comment actions Permalink

Adam,
please use non-minified version. You can find it, for example, here: http://code.jquery.com/jquery-1.7.1.js
It is sufficient just to put it under the project root if you are not going to use it in other projects or if you don't need to control which files in your project must not have jQuery completion. Of course you can create a library like you did earlier. Both methods should work.

1
Comment actions Permalink

WOW! I works! :)

I don't know what to say... I tried the non-minified version, but something was still wrong... Now it's okay.

But one more thing


On blog there was an info that I can enter a link to jQuery in <script> tag, and use Alt+Enter to add the lib to IDE. But all I've got is "Inject language >" when I press Alt+Enter on:

<script src="http://code.jquery.com/jquery-1.7.1.js" type="text/javascript"></script>

And ofcourse I deleted jQuery from libraries and filesystem first...

0
Comment actions Permalink

I have to check this, sounds like a bug.

0
Comment actions Permalink

Using non-minified jQuery 1.8.3. "Unresolved function of method done()" See attached screen shot for usage.



Attachment(s):
Capture.PNG
0
Comment actions Permalink

Works for me at least with WebStorm 6 both for jQuery 1.8.3 and 1.9.1. Is the library really enabled? (Settings|JavaScript|Libraries)

0
Comment actions Permalink

I'm fairly certain it is. You can verify with attached screen shot



Attachment(s):
Capture.PNG
0

Please sign in to leave a comment.