Javascript Debugging in Chrome, works in FF

So I have setup a remote js debugging project and initially I set the browser to Chrome, and while I could see it opening up a new tab, see connected to jetbrains Chrome Extension in the debugger frame, it ignored my breakpoints. On a whim I switched it over to FF and everything worked just fine. Anythoughts?

Thanks, Mark

8 comments
Comment actions Permalink

Oh I'm running Chrome:  24.0.1312.57
On Mac OS X: 10.8.2

0
Comment actions Permalink

Please see http://confluence.jetbrains.com/display/WI/LiveEdit#LiveEdit-HowDoIKnowWhatsWrong (How do I know what's wrong?) Please send me extension console content.

0
Comment actions Permalink
lastFocusedWindow is not normal browser-ext-platform.js:332
attachDebugger: existing dom not found browser-ext-platform.js:332
IN ["Debugger","sendCommand",[30,{"id":1,"method":"Debugger.enable","params":{}}]] browser-ext-platform.js:332
DC 30 Debugger.enable browser-ext-platform.js:332
IN ["Debugger","enableConsole",[30]] browser-ext-platform.js:332
IN ["Debugger","sendCommand",[30,{"id":4,"method":"Debugger.setBreakpointByUrl","params":{"condition":"","lineNumber":1,"url":"http:\/\/miniprojects.mindfulinteractive.com\/jstest\/js\/test.js"}}]] browser-ext-platform.js:332
IN ["Debugger","sendCommand",[30,{"id":5,"method":"Debugger.setBreakpointByUrl","params":{"condition":"","lineNumber":5,"url":"http:\/\/miniprojects.mindfulinteractive.com\/jstest\/js\/test.js"}}]] browser-ext-platform.js:332
DC 30 Console.enable browser-ext-platform.js:332
DR 30 Debugger.enable returns {} browser-ext-platform.js:332
DR 30 Console.enable returns {} browser-ext-platform.js:332
EV 30 Console.messagesCleared browser-ext-platform.js:332
EV 30 Debugger.globalObjectCleared browser-ext-platform.js:332
EV 30 Profiler.resetProfiles browser-ext-platform.js:332
EV 30 Console.messagesCleared browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332
EV 30 Debugger.scriptParsed browser-ext-platform.js:332



Attachment(s):
console_log.txt.zip
0
Comment actions Permalink

Hah, no it's  0.3.11. I think I got that from a link in the ide, I'll try installing the latest version fo the plugin.

Ok so I installed 0.5.4, but when I try to connect I am now seeing this in the inspector

Failed to load resource: the server responded with a status of 404 (Not Found) http://127.0.0.1:63342/browserConnection/buildInfo
127.0.0.1:63342 returns 404, may be it is IntelliJ Idea 12.0.x? browser-ext-platform.js:483
Failed to load resource: the server responded with a status of 404 (Not Found) http://127.0.0.1:63342/startTime
127.0.0.1:63342 returns 404, LiveEdit plugin is not installed, skip host browser-ext-platform.js:483


Do I need to update the PHPStorm so that it uses the right port or something?

0
Comment actions Permalink

And I get this in the console in the IDE

Waiting for connection from JetBrains Chrome Extension (see Console Tab for details) (if not, please see How to install JetBrains Chrome Extension by hand)

0
Comment actions Permalink

This issue fixed in WebStorm/PhpStorm 6, EAP is available, please use it.

0
Comment actions Permalink

Thanks it works now.


0

Please sign in to leave a comment.