0

Breakpoints not firing with XDebug

I just started out using PHP storm and am not that familiar with Apache so bear with me.  I am using Instant Wordpress to develop Wordpress sites on my desktop.  Instant Wordpress comes with MySQL and Apache built in so you just start it up and it creates a Wordpress instance at http://127.0.0.1:4001/wordpress.  I am using PHP Storm to edit the files in my custom theme folder in the Wordpress installation.  I'm trying to get XDebug to work for debugging.  

The XDebug DLL is already installed in a subfolder of the PHP folder and I have changed my PHP.INI file so that then I run a phpinfo() command in a test PHP file, it is reporting that XDebug is set up.  This is what I have in my php.ini file:

[XDebug]
zend_extension="C:\Development\iwp43dwmh\iwpserver\server\php\ext\php_xdebug.dll"
xdebug.remote_enable=1
xdebug.remote_port="9000"
xdebug.profiler_enable=1
xdebug.remote_host = "http://127.0.0.1:4001"
xdebug.profiler_output_dir="C:\Development\iwp43dwmh\iwpserver\server\php\tmp"
xdebug.remote_log="C:\temp\xdebug_log.txt"



I have set up the Server in PHP Storm to point to 127.0.0.1 port 4001 and created a Run configuration in  PHP Storm, called IWP, using PHP Web Application.  I have hooked the run configuration in to the server which I have already set up.  I have attached screenshots of my Project settings - Servers and Deployment Mapping tab.  Also my run configuration setting.

When I click Run - Debug IWP the browser fires up and goes to the URL:

http://127.0.0.1:4001/wordpress/?XDEBUG_SESSION_START={large number}

I can see a new debugging session starts up in PHP Storm.  However any breakpoints that I set in the PHP files are not hit.  I also tried ticking "break at first line in PHP scripts" but that also doesn't seem to hit anything.  Can anyone tell me what might be wrong or where to look?  Thanks

Attachment(s):
Servers.png
Deployment.png
Run_Config.png

1 comment

Please sign in to leave a comment.