phpStrom debug any page except the page inside Project dir

hi

my Os is:
linux mint14 - 64bit (Fork of Ubunut)

$ java -version
java version "1.7.0_13"
Java(TM) SE Runtime Environment (build 1.7.0_13-b20)
Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)

phpStorm version 5.0.4
PHP Version 5.4.6-1ubuntu1.1

my Xdebug config show in phpinfo():


and in php.ini config i have this:
[xdebug]
zend_extension=/usr/lib/php5/20100525/xdebug.so
xdebug.remote_enable=On
xdebug.remote_autostart=On
xdebug.remote_handler=dbgp
xdebug.remote_host=127.0.0.1
xdebug.remote_port=9000
xdebug.idekey=PHPSTORM

my phpStorm Config is:
http://www.axgig.com/images/51850672789497374848.jpg
and server config is:
http://www.axgig.com/images/84601211724820715544.jpg
now i press on debug and it's wating for xdebug:
http://www.axgig.com/images/66224320186264092777.jpg
i click on start xdebug bookmark and refresh the page:
http://www.axgig.com/images/31440969842925198277.jpg
but nothing happend and i see the Wating for .... message

but when i open anther link (pay attention here is untitled not untitled1):
http://www.axgig.com/images/41807859559577020901.jpg
this page automatically open in phpStorm and debug run:
http://www.axgig.com/images/08264448298763084394.jpg
see the message (this page is outside project)
thats very fantastic it debug all pages except the page i defined it for debug

any solutions ?

17 comments

Do you have any symbolic links there? Xdebug will send final (resolved/real) path and not symbolic link.


P.S.
Not 100% related .. just some notes:

xdebug.remote_autostart=On

With this you don't really need any bookmarklet/browser extension/etc to start debug session as xdebug should attempt to connect to debug client on every single request (you may notice about 1 sec delay for page to be processed).

Same with Run/Debug configuration (PHP Remote Debug) -- you can just use that "Start Listening for PHP debug connection" button (the one with phone handle icon) to start debug client .. and then just initiate debug session from browser (or it should be initiated automatically with that autostart option On).

0

Bazzik wrote:

Do you have any symbolic links there? Xdebug will send final (resolved/real) path and not symbolic link.


P.S.
Not 100% related .. just some notes:

xdebug.remote_autostart=On

With this you don't really need any bookmarklet/browser extension/etc to start debug session as xdebug should attempt to connect to debug client on every single request (you may notice about 1 sec delay for page to be processed).

Same with Run/Debug configuration (PHP Remote Debug) -- you can just use that "Start Listening for PHP debug connection" button (the one with phone handle icon) to start debug client .. and then just initiate debug session from browser (or it should be initiated automatically with that autostart option On).

No i don't have symbol link

both untitled and untitled1 folder has same content alson both of them are the projects made in phpStorm when i open untitled project then if i open untitled dir on webserver.it doesn't work and untitled1 worked and oppositive this

excatcly each project be open doesn't debug

also if i enbale this item then that pages outside project doesn't debug anymore
http://axgig.com/images/16471351602820976983.jpg
is it a bug and should i report a bug?

0

Hi there,

xdebug version? I suggest using latest stable which is 2.2.1.

My suggestion:

  1. Delete your "Run/Debug Configuration" as well as "Server config" (Settings | PHP | Servers) -- those on screens #1 and #2 in original post.
  2. Activate "Run | Start Listen PHP Debug Connections" (or the icon with phone handle on main toolbar).
  3. Make sure that "Ignore external connection ..." option is unchecked!
  4. Go to browser and navigate to the page you want to debug
  5. If necessary, activate debug session via Bookmarklet or browser extension and reload the page.
  6. PhpStorm should intercept incomming debug request -- it should show you the pop up window -- some think like below. Make sure to select correct path (since server is on the same computer, the paths should be identical). Maybe, the one you have created somehow differers from what PhpStorm is detecting (web server/php config??)


screen01.png
If it does not work ... please attach here your whole test project after all these manipulations (including .idea subfolder -- holds project configuration). I can try it here on my Windows 7 / IIS 7.5 / PHP 5.4.11 x32 nts via FastCGI

0

Also -- this screenshot of yours
http://www.axgig.com/images/08264448298763084394.jpg
I do see 2 index.php files opened -- one tab has normal backgound while another has yellowish background color.

Can you please show the full path for each of those files -- use "Navigate | File Path" on each of them (post 2 screenshots here).

0

BTW -- I do not see any breakpoints set on your very first screenshort.

I'm thinking -- xdebug may connect to PhpStorm just fine .. but since there is no breakpoints .. it will just run as normal. But .. for external (outside o fproject) script, it forces to break on first line (as shown on your latest screenshot).

0

Bazzik wrote:

Hi there,

xdebug version? I suggest using latest stable which is 2.2.1.

My suggestion:

  1. Delete your "Run/Debug Configuration" as well as "Server config" (Settings | PHP | Servers) -- those on screens #1 and #2 in original post.
  2. Activate "Run | Start Listen PHP Debug Connections" (or the icon with phone handle on main toolbar).
  3. Make sure that "Ignore external connection ..." option is unchecked!
  4. Go to browser and navigate to the page you want to debug
  5. If necessary, activate debug session via Bookmarklet or browser extension and reload the page.
  6. PhpStorm should intercept incomming debug request -- it should show you the pop up window -- some think like below. Make sure to select correct path (since server is on the same computer, the paths should be identical). Maybe, the one you have created somehow differers from what PhpStorm is detecting (web server/php config??)


screen01.png
If it does not work ... please attach here your whole test project after all these manipulations (including .idea subfolder -- holds project configuration). I can try it here on my Windows 7 / IIS 7.5 / PHP 5.4.11 x32 nts via FastCGI

my xdebug version is:
http://axgig.com/images/01018202851388147974.jpg
and it worked i got this:
http://axgig.com/images/33381315840476961936.jpg
after accept it worked but show this error
http://axgig.com/images/62981508196389871536.jpg
then i click on and set this path:
http://axgig.com/images/35512678005339593462.jpg
and that error disappear.but it just one time worked
and after that i create remote php debug and it didn't work anymore

0

Bazzik wrote:

Also -- this screenshot of yours
http://www.axgig.com/images/08264448298763084394.jpg
I do see 2 index.php files opened -- one tab has normal backgound while another has yellowish background color.

Can you please show the full path for each of those files -- use "Navigate | File Path" on each of them (post 2 screenshots here).


my path are:
http://axgig.com/images/06119608950282087467.jpg

0

Bazzik wrote:

BTW -- I do not see any breakpoints set on your very first screenshort.

I'm thinking -- xdebug may connect to PhpStorm just fine .. but since there is no breakpoints .. it will just run as normal. But .. for external (outside o fproject) script, it forces to break on first line (as shown on your latest screenshot).


also i put break point
it worked just one time

i did these steps and i also see the wating message (i reload more and more) not happend anything
it seems first time is just for add localhost then debug doesn't want work

http://axgig.com/images/73111530706708578500.jpg

0

I've no idea why it does not work for you based on your screenshots only. Therefore:
1) Please try v6 EAP build -- http://confluence.jetbrains.net/display/WI/Web+IDE+EAP
2) Actually please attach your test project (must include .idea subfolder)

0

Both projects are working (debugging) just fine here on my computer -- no modification to project settings at all.

Where do you put breakpoint(s)?

Breakpoint got triggered on for line .. but does not trigger on echo line (for whatever reason).

screen01.png
The only other thing I may suggest (considering that you do everything else properly) is to try v6 EAP build.

0

i put break point another where and it didn't work
im downloading new version (i hope it worked)

thanks anyway for your help and fast answers

0

Does debug works in CLI mode ("PHP Script" type of Run/Debug Configuration) ?

0

Bazzik wrote:

Does debug works in CLI mode ("PHP Script" type of Run/Debug Configuration) ?

i don't think so it is be a good way i want to work codeigniter and i think cgi php is better

i try new version and the problem is exists


it debug any page in my root direcotry except the pages inside project directory and it's very fantastic

0

i can give teamviewer to someone see if doesn't believe
im online on irc channel freenode.net my nick name is mintux  send me message
thanks everyone

0

Please sign in to leave a comment.