Enabling Jade Support in Webstorm 5.0.4

I was all excited when I saw Jade support come out in version 5 of Webstorm, so I downloaded a copy and am now going through the trial.

I had Webstorm 4 before, and imported my settings, and as far as I can tell, Jade is still getting treated as plain text.

Is there anything special that needs to be done to enable IDE support?

  • On my Mac, when I go to WebStorm > Preferences > Plugins, I see Jade is checked and marked as Bundled
  • In Preferences, when I search for Jade, I see
    • Code Style highlighting jade syntax
    • Colors & Fonts doing the same under Editors


And yet, when I create a new jade file with the jade extension (or from the context menu), I still get plain text.

Any ideas on how I could fix this?

Thanks!

2 comments

Hi Michael,

Please check "Settings | File Types" -- most likely that in previous version (which had no support for *.jade files) you have told IDE to treat them as Text File (IDE needs to know how to treat each unknown file extension). So .. please check "Text files" entry and remove any *.jade associated patterns from there (you may need to add *.jade to Jade files in the same settings page).

0

That worked perfectly. I removed the *.jade wildcard from the Text File association and added it to the Jade File.

0

Please sign in to leave a comment.