Unable to Create Node.js Express App

Just downloaded Webstorm to try out with Node.js.  My first attempt isn't looking so good.  I'm trying to create a new Node.js Express App project.  Node is running on my machine just fine, and I was able install express with npm, but something is failing when WebStorm tries to grab it:


9:06:28 AM Create Express Project: Error creating Node.js Express App. Express module is not found


The project is then built in a mostly empty directory.  What am I missing here?
6 comments
Comment actions Permalink

What OS do you work on? Can you provide your idea.log?


0
Comment actions Permalink

Log file is attached.  Running on Windows 7 64-bit.  Tried with both x86 & 64-bit versions of Node, no dice.

Looks like it's bailing at:

xpress.ExpressProjectGenerator - Executing '"C:\Program Files\nodejs\npm.cmd" install express@3.1.0' in 'C:\Users\jrapp\WebstormProjects\untitled9'...
WARN - xpress.ExpressProjectGenerator - Express module is not found



Attachment(s):
idea.log.zip
0
Comment actions Permalink

thanks for details... can you try to cd to 'C:\Users\jrapp\WebstormProjects\untitled9' and execute '"C:\Program Files\nodejs\npm.cmd" install express@3.1.0' from this directory in command line?

0
Comment actions Permalink

That worked fine.  Now there's an express directory under node_modules that's completely populated.  I downloaded WebStorm to a Windows 8 VM running on my computer, and it worked fine, so there's something up with my install.  I also removed WS from my computer and reinstalled, but no dice.

0
Comment actions Permalink

Please, can you try the latest WebStorm6 EAP (http://confluence.jetbrains.com/display/WI/WebStorm+6+EAP)? We have added some additional logging there (stdout and stderr output when executing npm commands) to be able to track down the problems like yours...

Thanks in advance:)
Lena

0
Comment actions Permalink

Lena -

Thanks for the help. I think I got it figured out.  I had customized my windows command prompt to auto switch to the c:\ directory when it was started:

HKEY_CURRENT_USER \ Software \ Microsoft \ Command Processor \ AutoRun

Took that out, and now it works.

0

Please sign in to leave a comment.