Fine print.

I have two questions both are on the little status bar that I see on the bottom of WebStorm IDE.

1. I see a message 'Unregistered Git root detected: The directory <Directory Path> is under Git, but not registered in the Settings. .....' This is not the whole message but I cannot see the whole message. What do I do? How do I 'register' a Git directory? What settings do I modify?
2. Also on the status bar I see at the far right text like '107M of 494M'. What does this indicate? What if it reads closer to the supposed maximum of 494M. How do I modify this value?

Thank you.

3 comments

Hi Kevin,

1. I see a message 'Unregistered Git root detected: The directory <Directory Path> is under Git, but not registered in the Settings. .....' This is not the whole message but I cannot see the whole message. What do I do? How do I 'register' a Git directory? What settings do I modify?

Settings | Version Control -- somewhere there. I assume that PhpStorm detected presence of special files used by git (e.g. .git, .gitignore etc) and suggests to set it up properly.

P.S. You should be able to see whole message in "Event Log" toolwindow.

2. Also on the status bar I see at the far right text like '107M of 494M'. What does this indicate? What if it reads closer to the supposed maximum of 494M. How do I modify this value?

You do not need to worry about it -- those default settings are fine for almost every project. If you click on it the Java Garbage Collector will do its job and left value will drop lower (some temp buffers/indexes will be dropped etc). You can hide this info at "Settings | Appearance | Show memory indicator".

In case if you need to modify those settings -- look at *.vmoptions file where it is installed (e.g. on Windows 7 it would be PHP_INSTALL_FOLDER\bin\PhpStorm.exe.vmoptions ). In any case -- if IDE will require more memory, it will inform you.

0

GIT is setup correctly. I have published successfully. What is wrong? Also as I indicated this is for the WebStorm IDE if it makes any difference.

0

Hi Kevin,

GIT is setup correctly. I have published successfully. What is wrong?

Don't know -- maybe you will find your answer here: http://youtrack.jetbrains.com/issues/IDEA?q=Unregistered+Git+root+detected

Also:

Also as I indicated this is for the WebStorm IDE if it makes any difference.

No difference for VCS integration. If it is regarding paths to the file (PHP_INSTALL_FOLDER\bin\PhpStorm.exe.vmoptions) then just change to the WebStorm equivalent.

0

Please sign in to leave a comment.