Whats about WAI-ARIA Support?

Hi,

does not  support phpstorm aria attributes like role oder aria-* in html tags?

Increasingly accessibillity plays a big role during my web development projects (not in yours?), so it would be nice if phpstorm would support aria attributes!

Bye
tom

3 comments
Comment actions Permalink

Tom, I'm using the latest PhpStorm EAP build #126.92 and "role" attributes works well. This should also work in PhpStorm/WebStorm 5.0.4.
Could you please ensure that you have HTML 5 doctype in your file: <!DOCTYPE html>?
You also can set HTML 5 as a default language level for editing the HTML/XHTML files where doctype is not specified explicitly in your settings: Project Settings | Schemas and DTDs | Default HTML language level.

0
Comment actions Permalink

Hi,

thanks, after setting to Language Level to html5 the role attribute is known, but there are no suggestion according to the possible values.
What I'm still missing are the aria-* Attributes. At the moment I'm forcing new coding standard to our projects and the most developer are not familiar with the wai-aria tags!
So it would be very helpfull if phpstorm supports it.

0
Comment actions Permalink

Tom, thanks for clarification! Could you please create a new feature request in our tracker?

0

Please sign in to leave a comment.