WebStorm does not responding.

I tried to use WebStorm 6 EAP 126.37.
seeing high CPU usage caused by indices update and not responding over a hour.

I tried this command and re-open, but still not responding..

$ rm -rf ~/Library/Preferences/WebIde60
$ rm -rf ~/Library/Logs/WebIde60
$ rm -rf ~/Library/Application\ Support/WebIde60
$ rm -rf ~/Library/Caches/WebIde60


$ cat package.json

{
        "name": "not-responding",
        "version": "0.0.1",
        "private": true,
        "engines": {
                "node": "0.8.18",
                "npm": "1.2.2"
        },
        "scripts": {
                "start": "node app"
        },
        "dependencies": {
                "typescript": "0.8.2",

                "grunt-contrib": "0.3.0",
                "grunt-typescript":"0.0.8",
                "grunt-compass":"0.3.7",
                "grunt-jasmine-task": "0.2.3"
        }
}
$ npm install
# open directory by WebStorm



WebStorm stops in scanning under node_modules/ and use CPU 100%.
The folder is open if exists fewer files.

What could be something to try?

My environment
Mac OS X 10.8.2 MBA Mid 2012

java version "1.6.0_37"
Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-11M3909)
Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01-434, mixed mode)

7 comments
Comment actions Permalink

Masahiro, may I ask you to zip and attach log directory that opens on Help -> Reveal log?

Thanks,
Kirill

0
Comment actions Permalink

this one.
Thanks in advance.



Attachment(s):
idea-log.zip
0
Comment actions Permalink

Thanks. Does it happen every time? What if you force quit the app and start it again?

0
Comment actions Permalink

Hi,

double the issue... after update to 126.37 WebStorm stop working on my Node.js based project.
First it was claimed 800 MB memory is not suffitient. After increase it to 1GB it hangs on opening the project.
My log & thread dumps are attached

Cheers, Oleg



Attachment(s):
WebIde60.7z.zip
0
Comment actions Permalink

Hi guys,

Looks like the problem has to do with LESS/CSS parsing.

Oleg, could you please attach grunt-contrib-less/node_modules/less/test/less/css-3.less file here or send it to me privately to kirill (dot) safonov (at) jetbrains (dot) com? Or is it maybe on github? :)

Thanks!

0
Comment actions Permalink

Thanks, we've reproduced the problem locally. This is a critical bug (tracked as http://youtrack.jetbrains.com/issue/WI-16352) and we expect to release the fix at the beginning of the next week. Meanwhile please disable LESS plugin or roll back to the previous EAP build.

0
Comment actions Permalink

Kirill

Thank you for advice!
I am not use the LESS.
My project was fixed change dependency "grunt-contrib" to "grunt-contrib-clean" (exclude grunt-contrib-less).
It works fine on WebStorm EAP 126.37, thanks a lot :)

0

Please sign in to leave a comment.