It's like sharing your bench with a hog

Every so often phpstorm will elbow me aside. So I pause and wait then get back into position and start playing again.

Sometimes it shoves me right off the bench, and I have to kick it out and restart.

Yes I understand it has all this background processing to do.

But it has no brains for deciding when it needs to kick in.

On the occasions when it hasw chosen a really annoying moment to nudge me off the bench, is there a fast button I can hit somewhere that say "Not now you jerk, I'm busy" ?

9 comments
Comment actions Permalink

Thanks David,

Do you mean IDE is slow or unresponsive for a time?
How large is your project?

Kirill

0
Comment actions Permalink

Yes.

Some slowdowns pass quickly. Others require stop and wait. Once a week or so it freezes completely.

Project sizes are hard to know exactly, but in the range of 50 - 150MB each. I usually need to work on 2-4 projects at the same time.

Most of the time I get it. I understand I generated some large file and phpstorm feels obliged to process it somehow.

I cannot avoid generating these files and I cannot place them outside the project.

(unless there is a way to exclude files from a project?)

I wish for a way to say stop. Wait and let me (a) finish what I am doing and (b) remove the file which is choking you.

I am happy to "invalidate caches and restart" every so often. I just wish it could be when I am not in the middle of something else ;)

0
Comment actions Permalink

Are these large files PHP?

You can mark a file as plain text (context menu action in project view) so IDE does not parse / index / highlight it.

Also you can exclude a complete directory from the project (main menu -> Settings -> Directories, look for 'Excluded' button at the top).


Kirill

0
Comment actions Permalink

The large files are javascript.
Okay I will try "mark as text", that is something I was looking for, thank you.

But you are trying to debug/attack the issue by examining or changing the inputs.

Regardless of specifics for any project, is there a way to halt all background processing with a keystroke? Because the mouse has gone away...

Once phpstorm decides to get busy, is there any way to bring it back except either wait for it,  or force quit the whole tamale?

0
Comment actions Permalink

Nope, you cannot stop background highlighting except than typing in the editor (you can turn it off completely but I guess this is not what you want).

To help us find the bottleneck could you please take a CPU snapshot?

Thanks,
Kirill

0
Comment actions Permalink

Turning it off will be fine. The alternatives are not feasible today.
It is Christmas Eve. No time to play phpstorm developer.
I want this thing to let me edit, period. Then go home!!!

Do not anaylze, index, try to access the internet or attempt any intelligence.
Let me type!

What are all the switches that will turn this thing into a dumb editor?

0
Comment actions Permalink

Try File -> Power save mode

0
Comment actions Permalink

David, you might want to check out this video "WebStorm, get out of my way!": http://www.youtube.com/watch?v=GEwjDeof1ak

0
Comment actions Permalink

Thank you for that.
Good to know. Sometimes I'd just rather type. But mostly I want the intelligence.

No, it is the huge pauses while background tasks chug away that annoy me.
Yet my situation is uninteresting: I checked the "performance problems" page and nothing applies. I  run pedal to the metal with no other tasks.

What I do have is a bunch of ThreadDumps.

I notice they are in sub-folders WebIde10,WebIde40,WebIde50. Looks like new versions  don't clean out the old ones.
I will have to take the time to file a ticket one day.

But this year, like every year, I first have to go to support to find out why I'm still getting "your license is expired" after paying and updating. Grr.
But I want to edit. I got my own problems. I do not want to be an editor beta support debugger person ;)
Wah wah wah and blah.

0

Please sign in to leave a comment.