[SOLVED] Webstorm doesn't remember spaces(tabs) on empty lines after minimizing

1. Create opening and closing tags, eg: <header></header>
http://i.imgur.com/ttyAF.jpg
2. Click enter so you get

<header>
  |
</header>

where "|" is the caret

http://i.imgur.com/kKzNV.jpg

3. Put the caret somewhere else in text. At this point you'll see the spaces in the beginning of the line like so:

<header>
..
</header>

http://i.imgur.com/Cyq4b.jpg

4. Press alt-tab. Press it again. No spaces anymore. So if you place cursor in this line the caret will be in the beginning of the line without indentation, like so:

<header>
|
</header>

http://i.imgur.com/zXrFF.jpg
It's a little annoying. Sometimes i like to create a structure of the document and then fill it with content. And i'm learning HTML so i have to ALT-TAB very often to keep up with the lessons.

Is there anything i can do about it?

4 comments
Comment actions Permalink

Hi Leonid,

Choose whatever better suits you:

  • Settings | Editor --> Strip trailing spaces on Save -- that's about stripping space chars
  • Settings | General --> Save files on frame deactivation (e.g. on Alt+Tab) -- that's if you want to prevent IDE from saving files when switching to another app.
0
Comment actions Permalink

Thank you, Andriy!

I set "Strip trailing spaces on Save" to "None" and the problem is solved :)

0
Comment actions Permalink

Great!

Check out Live Edit plugin -- it may help minimizing AltTabbing for you (works with Chrome browser)

http://blog.jetbrains.com/webide/2012/08/liveedit-plugin-features-in-detail/

0
Comment actions Permalink

Thank you again :) !!!

0

Please sign in to leave a comment.