"Unexpected character" error when attempting to add TFS server to WebStorm

The error I'm seeing: com.ctc.wstx.exc.WstxUnexpectedCharException: Unexpected character '" (code 34) in DOCTYPE declaration; expected a space between public and system identifiers at [row,col {unknown source}]: [1,50].

Currently running TFS 2010 and WebStorm 5.0.4. I don't see the TFS plug in version, but it was *just* downloaded.

Thoughts?

4 comments
Comment actions Permalink

This is the same issue, but the poster never responded to say what the configuration was: http://devnet.jetbrains.net/message/5316269#5316269

I noticed another thread asking for what happens when you visit the TFS URL in a browser.

The address I use in Visual Studio is...

http://dev-blah:8080/tfs

If I visit that in a browser, I am redirected to...

http://dev-blah:8080/tfs/web/

...with a nice web interface.

Best,
nz

0
Comment actions Permalink

Nathan,

Can you turn on TFS logging and send me your logs at kirill (dot) safonov (at) jetbrains (dot) com?

Thanks,
Kirill

0
Comment actions Permalink

I can not for the life of me get that file to save. Nothing I do changes the bin folder from read-only. If you have an idea on that, I'm happy to get you the log.

I'll leave my work around here as well:

  1. Use the fully qualified domain: http://blah.example.com/tfs instead of http://blah/tfs
  2. Don't use system credentials, type them in manually.
  3. Don't enter a domain in the credentials area.


Changing those three things has this working through my Mac and Win7 machines.

nz

(For anyone that stumbles across this, there is a big filed here: http://youtrack.jetbrains.com/issue/IDEA-97798)

0
Comment actions Permalink

...and final update to this. Both short and long URLs ended up working. The trick was no uncheck the system credentials and enter in the details there. Adding / removing the domain portion didn't affect it like I thought.
Sorry for the confusion. Hope it helps someone!

nz

0

Please sign in to leave a comment.