don't ask password

Hi!
I tried to pull my project from git repo and when PhpStorm asked me password, I pushed the close button and after that PhpStorm don't ask me password.
How can I fix it?

7 comments
Comment actions Permalink

Hi,

Do I correctly understand that you pressed the close button instead of entering the password?
And what happens afterwards? PhpStorm doesn't ask you the password, but shows an error?

0
Comment actions Permalink

Yes! You understood me right.

Now, when I pull or push project PhpStorm don't ask me any questions or show any windows and return "fatal: The remote end hung up unexpectedly".
I use Windows 7 and PhpStorm 5.0.1

I copy text from my Version Control Console:

16:50:20.720: cd D:\Projects\www\mad 16:50:20.721: git pull --no-stat --log -v --progress origin master java.io.IOException: Keyboard-interactive authentication failed.      at com.trilead.ssh2.auth.AuthenticationManager.authenticateInteractive(AuthenticationManager.java:391)      at com.trilead.ssh2.Connection.authenticateWithKeyboardInteractive(Connection.java:271)      at com.trilead.ssh2.Connection.authenticateWithKeyboardInteractive(Connection.java:213)      at org.jetbrains.git4idea.ssh.SSHMain.authenticate(SSHMain.java:241)      at org.jetbrains.git4idea.ssh.SSHMain.start(SSHMain.java:156)      at org.jetbrains.git4idea.ssh.SSHMain.main(SSHMain.java:136) Caused by: java.io.IOException: Sorry, this connection is closed.      at com.trilead.ssh2.transport.TransportManager.sendMessage(TransportManager.java:636)      at com.trilead.ssh2.auth.AuthenticationManager.authenticateInteractive(AuthenticationManager.java:337)      ... 5 more Caused by: java.io.IOException: Invalid PEM structure, '-----BEGIN...' missing      at com.trilead.ssh2.crypto.PEMDecoder.parsePEM(PEMDecoder.java:138)      at com.trilead.ssh2.crypto.PEMDecoder.decode(PEMDecoder.java:313)      at com.trilead.ssh2.auth.AuthenticationManager.authenticatePublicKey(AuthenticationManager.java:171)      at com.trilead.ssh2.Connection.authenticateWithPublicKey(Connection.java:443)      at org.jetbrains.git4idea.ssh.SSHMain.tryPublicKey(SSHMain.java:336)      at org.jetbrains.git4idea.ssh.SSHMain.authenticate(SSHMain.java:215)      ... 2 more fatal: The remote end hung up unexpectedly



I deleted folder with project, and made clone repo again. But trouble did not fix :(

I'm sorry for my bad English.

Thank you.

0
Comment actions Permalink

I installed PhpStorm EAP 124.237. But trouble did not fix. Could it be to related to git settings? But when I pull at the console, git ask me ssh password.

0
Comment actions Permalink

It seems that you have an incorrect id_rsa private key: without the starting section which should look something like

-----BEGIN RSA PRIVATE KEY-----¬                                                                
  2 Proc-Type: 4,ENCRYPTED¬
  3 DEK-Info: DES-EDE3-CBC,E11255C5A63924


Please try to regenerate SSH keys and see if that helps.
0
Comment actions Permalink

This is text from id_rsa file:

PuTTY-User-Key-File-2: ssh-rsa Encryption: aes256-cbc Comment: Public-Lines: 4 AAAAB3NzaC1yc2EAAAABJQAAAIEAm8FflaxjGIwHyquLdcJpFWWR5cd6MowzpanD ak/9HqiGmS6QT5og0HhcIjdvpHue7khE3t/3Mfg6L3nubK8kHu6fVgJcdxsKd5e+ KxeReHiH3R+T1CDinuo78DW8xg1l54Hy9n/+g8BhvTdAWaMbtQm763qaUlRA+U+7 I37fFnk= Private-Lines: 8 x2aJYz1RWHxQRK2HS2/kjw/nFEt+CTnB9eU3vyR6aBmtqsJdF0PewNnE8OySfRpb bvlytmMWbcCYXG15VkBE0gFE76aqG8NHpS2rbNQ12rHugk/kNPpRAGwNjbZx+A5D WpvPHjKTUlF41C/OcPEG7Zr64GSfhBj01pmZrNdFYfFlp0mqLiGJxoV5JJ7yM7x1 +QgQaBr9uZRZgQV6f8wN0p4YtNM4UZ6sbXxjor2bq83yoIxG+sb1zDzoixoN6NNe bwBqanYZ+coDW+siyegWjhcfNah7w6AcyLBIzTLzQH3KffFRzMxUJrS7N7d/V1in wt36eXBNmcOHb4MwWDw7w7px+eSvj8HWTXd/2HRdiwnGm783qDun9jtuGG0Br+A6 /WIwPENzX7GjevnQrcMMvC+nptpZMk9PvrPYEbCVSC4b1WorUTwcEx92E0d2tUNG 8kISujHvUMFtp55BsWBZ9Q== Private-MAC: 5449457d4b5d4db37f9ds8d598ebgc534aa6baa8


This is text from id_rsa.pub file:

ssh-rsa AAAAB3NzaC1yc2EAAAABJQAAAIEAm8FflaxjGIwHyquLdcJpFWWR5cd7MowzpanDak/9HqiGmS6QT8og0HhcIjdvpHue7khE3t/3Mab6L3nubK8kHu6fVgJctxsKd5e+KxeReHiH3R+T1DDinuo78DW8xg1l54Hy9n/+g8BhvTdAWaMbtQm869qaUlRA+U+7I37fFnk=



P.S. I changed some letters in the key

0
Comment actions Permalink

Thank you very much!!!

I regenerated SSH keys by GIT Bash like that and after PHPStorm started use them.
I'm very happy.

Thank!

0
Comment actions Permalink

You're welcome.

Great that the problem has been solved.
0

Please sign in to leave a comment.