Turning of file contents caching

I am using a simple methodology, as a do-it-yourself revision control

For each task I have a separate copy of the whole code, named after the task (task1, task2 etc.)
At any given moment I only work on one task.
To start working on a task, I rename the task's folder into "working copy".

Now, each task folder, also has in it a .idea folder, with PhpStorm's project files.

Currently I use the following procedure to switch between tasks
1. Close the project (but not Storm)
2. Rename folders (resulting in a different task-folder named now as "working copy"
3. Reopen the project on Storm

Now to the problem: storm opens files with *the wrong content*. It seems to somehow remeber the content of the file (even though the file was not open in any tab), and ignore the fact the the file has changed on disk.
Now I see that when i edit the file, storm gets notified by the OS, and reloads the file. But when I merely rename the containing folder name, it does not.

Is there a way to turn of this "caching" mechanism, and force Storm to always load newly opened files from the disk?

3 comments
Comment actions Permalink

Hi there,

No, you cannot turn off such "caching". You can try using "File | Synchronize" after such "rename" operation. ("File | Invalidate Caches" will work even better).

P.S.
Why not actually invest a bit of time into learning, installing and actually using proper VCS (git, mercurial or whatever)? It's definitely a better and more convenient solution than your current workflow.

0
Comment actions Permalink

Andriy, thank you.

As of the git/mercurial option, will this be enough to prevent the described problem? Those tools change the contents of the code folder as well

I'll also notice, that what I am doing is actually renaming, without quotes. And is very convenient in my scenario. I am forced to use my companies central CVS, and creating here a simple solution for local branches. And what storm is doing is again, caching, without quotes. I hear what you are saying that it cannot be turned off.

0
Comment actions Permalink

The general recommendation is: separate project per branch (as described in these links and other places):


Maybe you need to use the same approach.

Unfortunately I'm not using any VCS myself (so far I'm managing my stuff just fine without it) and cannot give any real advices in this regard.

0

Please sign in to leave a comment.