Monaco font on Ubuntu with phpStorm

hey everyone,

Im am using phpStorm on both mac osx and ubuntu linux. However, i want both editor's to look as similar as possible.

I'm using monaco (mac default font) as the font-of-choice for phpStorm, and have succesfully installed it on ubuntu (i've got unity using the font, and just about everything else)

But whenever i try to select the font, it doesn't show up in the font list (even though its installed on the system).

Does anybody have a clue on how this can be fixed?

Thanks,
darthness

7 comments
Comment actions Permalink

Hi there,

If you have installed it while PhpStorm was running then try restarting PhpStorm as it only loads list of fonts once per session.

Otherwise -- no clue (not Linux user).

0
Comment actions Permalink

This does not fix the issue, as i restarted my pc multiple times and it still doesn't show up in the font list.

0
Comment actions Permalink

Can you use it in other JAVA-based applications?

0
Comment actions Permalink

Yeah works fine in any other application.

Edit: Works in eclipse (i think thats also java-based)

0
Comment actions Permalink

Eclipse -- yes, it is Java based, but it uses different way for rendering fonts and user interface (PhpStorm uses Swing) -- maybe it has something to do with it (does it work in NetBeans, which uses Swwing as well ?).

This ticket is not directly related to your issue, but maybe you will find some useful info : http://youtrack.jetbrains.com/issue/IDEA-57133, http://youtrack.jetbrains.com/issue/IDEA-57233 (e.g. possibly you have installed bad version of Monaco font... -- maybe try the one described here: http://www.keleko.com/2012/better-font-rendering-in-phpstorm-on-linux/ )

0
Comment actions Permalink

Allright, i'll give it a try when i get home. Thnx!

0
Comment actions Permalink

I use monaco font too on kubuntu, it doesnt show up unless you uncheck the 'show only monospaced fonts' checkbox.

0

Please sign in to leave a comment.