PHPStorm: Enabling PHP Interpreter

Hello JetBrains community,

I've installed PHPStorm for the first time (version 5.04) and now I'm trying to enable the PHP interpreters. As WAMP, I use easyPHP. According to the manual, I should tell the IDE where to find the php.exe file. When I do that, I have a strange warning message.

PHP Warning: PHP Startup: Unable to load dynamic library

stormerror.png

At this point I'm really confused and I don't know what to do. It would be very kind if someone could help me.
I've check the extension_dir of my php installation and it's correctly set. What is the problem?

K.R.

D.



Attachment(s):
php.ini.zip
4 comments
Comment actions Permalink

Hi there,

Accordingly to the php.ini (that one you have attached) it is set to "${path}\php\php546x120827120553\ext\".

TBH I do not know what ${path} does here (how it works) but apparently the path is not getting properly resolved .. or PhpStorm does not have enough permissions when it tries to execute php.exe to find out what version it is etc. It may work fine when request comes via browser .. but may not work when called from command line.

To verify that -- open command line (cmd.exe) in that folder (where php.exe is) and execute "php.exe -v" or "php.exe -i" and see how it goes.

Therefore I suggest setting proper full path to extensions folder instead of "${path}\php\php546x120827120553\ext\" (e.g. "C:\WAMP\php\php546x120827120553\ext\") or path relative to the php installation (e.g. just "ext" may work -- at least it does for me in my manual (independant php) installation).

0
Comment actions Permalink

Hi Andrey,

Thanks for the reply. I've changed my php.ini according to your recommendations. And now when I launch "php.exe -i" in the cmd-windows I once again recieve a warning message. This time, the php_yaz.dll can't be found...
This time I'm really confused, since I think the path was set correctly and the previous warnings are gone.

Here a screenshot of the warning message
php_yaz_not_found.png

and the php.ini



Attachment(s):
php.ini.zip
0
Comment actions Permalink

Hi there,

1) Please make sure that the problematic file (php_yaz.dll) is actually there.

2) Make sure that php_yaz.dll is compatible with PHP v5.4

3) Please check documentation for that extension (as it is not standard 5.4 extension) -- maybe it depends on other DLLs (or whatever) to be present ?

Other than that -- don't know. It's hard to suggest anything more useful from overhere.

0
Comment actions Permalink

Hi,

the he problematic file (php_yaz.dll) is indeed in the [ext] folder. As i said before, i use easyPHP as WAMP. Now I've installed "xampp" and everything went just fine.  The xampp version I've installed comes with php 5.4.7, while easyPHP is delivered with PHP version 5.4.6 and PHP version 5.4.8.

Now while writing this message, I've just edited the php.ini of easyPHP to comment the line declaration of the problematic extension (;extension=php_yaz.dll) and now PHPStorm can register the interpreters. Maybe as you said the extension is not compatible with php version  5.4.x.


Thanks a lot for your assistance!!!

0

Please sign in to leave a comment.