Setting Up Live Edit

I'm having trouble figuring out how Live Edit is supposed to work. Here's what I have:

PhpStorm 5.0.2
Chrome 22 with JetBrains Chrome Extension 0.3.1
Apache 2.2.22
PHP 5.3.15
OS X 10.7

I'm developing a WordPress website. The local domain is wp.gentoo.

I've checked the "Live Edit" option in the "View" menu.

Chrome is the only "Active" browser on the "Web Browsers" settings page. Specific settings for Chrome:

  • "Command line options": none
  • "Use custom profile directory": unchecked
  • "Enabled remote debug on port": checked, 7930


My WordPress theme has the normal style.css file. How do I make Live Edit work, such that when I make changes to style.css, those changes are reflected in Chrome?

I can tell it to open style.css in the browser, which simply opens the css file in the browser. I can tell it to "Reload in Browser", which accomplishes nothing.

I appreciate the help.

25 comments

Just tried PhpStorm 5.0.3 (121.351) -- does not work as well (worked in v5.0.2). Windows 7 x64 SP1 ENG;

Extension was updated in Chrome automatically -- now v0.3.10

idea.log says:

2012-10-23 14:44:09,011 [  22407]   INFO - erConnection.BrowserConnection - Browser connected: version 0.3.10, CHROME

Based on the above I would assume that it actually works, but no reaction from browser at all (when making changes to the file) or IDE (usually IDE would save the file as soon as I finish typing, but not in this case)

Domain: idetest.localtest.com -- resolved via local DNS server to 192.168.0.2
Deployment option is configured properly (when I use "View | Web Preview..." it opens correct URL)
File in question: plain fully formed HTML (XHTML 1.0 Strict) named testing\html.html

0

It seems 5.0.3 contains broken JB extension. New version of extension will be available soon (this thread will be updated).

0

Thanks, Vladimir. Looking forward to it.

0

1) Install JB extension https://dl.dropbox.com/u/43511007/jb-3.10.crx (Open chrome://chrome/extensions/ and drag the file onto the Extensions page.)
2) Open Settings -> LiveEdit. Uncheck "Enable live editing". Close Settings. Open settings again and check "Enable live editing"

0

Working fine, thnx.

P.S.

Settings -> LiveEdit. Uncheck "Enable live editing"

If I understand it correctly, it is the same as "View | Live Edit", right ?

0

BTW -- one HUGE (for me, at least) question.

When this extension will work with 127.0.0.1 IP address? (i.e. when domain name resolves to 127.0.0.1 instead of "proper" 192.168.x.x or so)

0

Must work for 127.0.0.1 (i.e. http://localhost).

0

Yes, it is the same as "View | Live Edit". But in this case it is important to use only Settings -> LiveEdit -> ....

0

Well -- maybe with localhost only (have not tested localhost BTW) -- but it definitely does not work with fake names, e.g. idetest.localtest.com, project1.localtest.com. I have one domain (or subdomain in this case - whatever is the correct term will be) per project -- all of them are fake:

  • at work it is resolved using proper local DNS server (MS DNS on Windows Server 2003) and pointing to 192.168.0.2
  • at home it is resolved via hosts file and pointing to 127.0.0.1


It works at work but does not at home.

BUT, if at home I edit hosts file to point to 192.168.0.2 -- it suddenly starts working again... (or, if I alter DNS server settings to point to 127.0.0.1 it also stops working at work).

Based on such information/details I have only one conclusion -- LiveEdit does NOT work with 127.0.0.1 IP.

0

Thanks, Vladimir. I have it working with the latest version of the extension. And thank you, Andriy; you're information was vital.

dnsmasq is routing my local domains to 127.0.0.1. With that setting, nothing was working. I changed my config to point to 192.168.1.67 (my local IP address), and Live Edit is, indeed, working.

0

Just for clarification: is your server (pointing to 127.0.0.1) configured as Deployment Server (Settings -> Deployment) (don't worry, it is not required, just for clarification)?

0

Fixed. (Will be available as part of LiveEdit plugin for next idea 12 EAP and as part of WebStorm 6 EAP).

0

Just for clarification: is your server (pointing to 127.0.0.1) configured as Deployment Server (Settings -> Deployment)

Yes

screen01.png
screen02.png

Fixed. (Will be available as part of LiveEdit plugin for next idea 12 EAP and as part of WebStorm 6 EAP).

Great -- thanks.

May I ask why not in v5.0.4? Is it really incompatible with 5.xx code base?  Based on number of issues yesterday's 5.0.3 has, I definitely see 5.0.4 coming next.

0

why not in v5.0.4

Ok. Also, 5.0.4 contains another fixes – 1) http://youtrack.jetbrains.com/issue/WI-13445 2) Now you can configure any server (even not on localhost) as Deployment Server and it will be inspectable

0

I have tried your fix on a fresh webstorm install in windows and it work perfectly. However I have been using WebStorm in ubuntu....I have updated to WebStorm 5.0.3 and I found 2 issues. First when I try to open my html file from webstorm it opens it in a different window with no add ons installed which is weird since I have like 7 add ons installed in chrome including JB. I dont know if this is because I updated chrome as well or what.

Also, before (WEbStorm 5.0.2) I was able to open my html file from my folder browser and still was able to use live edit. I did this since WebStorm was opening the file in a totally independent chrome window with no addons and still the extension was not working. I try uninstall it and install it again and no luck.

Is there an extra step I have to do in linux? or you recommend a fresh install like I did in windows? If I have to do a fresh install, will removing the directory into which I have unpacked it and deleting ~/.Webstorm* will suffice?

Thanks

Ser

0

Please ensure that Settings -> Web Browsers -> Chrome pointing to correct browser. Also, please, could you send me idea log (Help -> Reveal Log in) (open issue http://youtrack.jetbrains.com/issues/WI#newissue=yes and attach or just send to vladimir.krivosheev@jetbrains.com)?

0

Hi, 5.0.3's live edit has also stopped working for me. I tried what you described above and can't get it to work at all.

0

What is your OS? If Linux (Ubuntu), please wait 5.0.4.

0

Same with me. I just recently updated to 5.0.3, and it stopped working for me. Please help! :(

I installed the new extension and did everything as told. I can see the small eye icon at the corner of the editing window, but there is no real time change in google chrome's HTML.

I gave the extension full access to file URLs and everything and it is still not working.

My OS is Windows 7 x64 bit.

0

John Camacho, John Rhodes please send me idea log (Help -> Reveal In …) (open issue http://youtrack.jetbrains.com/issues/WI#newissue=yes and attach or just send to vladimir.krivosheev@jetbrains.com)

0

I am experiencing the same problem on windows 7 64bit, running a local project on WAMP. After upgrading to 5.03 and manually installing the plugin I still get a 'connecting to plugin' message in the console which never resolves. Feel like I may be missing something obvious?
Thanks.

Tom

0

Great work on 5.0.4 guys....Live Edit works now.

Thank you!

0

Please sign in to leave a comment.