Using Composer - PHPUnit Configuration Problems

Anyone using Composer with PHPStorm and running PHPUnit? It's such a different configuration. Seems I'd have to make a log of manual configuration changes to make it work. Am I missing something?

4 comments
Comment actions Permalink

I found a way to make it work, but it's not a good way. I can add this to the PHPUnit/Autoload.php file:

46 require_once 'autoload.php';


Which will load the composer autoloader. Not a way that I can use, but just tried it for testing. Any suggestions?

0
Comment actions Permalink

Am I the only one trying to use Composer or the only one with these issues?

0
Comment actions Permalink

Ah, thanks.

Should have just searched the bug tracker.

  • WI-13046 Support for Composer - http://youtrack.jetbrains.com/issue/WI-13046
  • WI-13429 Using phpunit from composer - http://youtrack.jetbrains.com/issue/WI-13429
  • 0

    Please sign in to leave a comment.