could not debug script with Zend Debugger

Salutations

I have PHPStorm 5.0.1
This is first time when I was trying to debug php scripts after updating PHPStorm to 5.0.1.

I want to debug my script with zend debugger but I always get this notification "Connection with 'xdebug' was not established".

I have visited this page
http://www.jetbrains.com/phpstorm/webhelp/configuring-zend-debugger.html

but I even do not see "In the PHP page that opens, choose Zend Debugger from the Debugger drop-down list.                      "
Where is Debugger drop-down list?
And how I can use Zend Denugger?
Or Zend Debugger Support has gone?


thanks

3 comments
Comment actions Permalink

and one more
PHP 5.3.10 x64

here my phpinfo

[PHP Modules]

.....

xmlrpc
xmlwriter
xsl
Zend Debugger
zip
zlib

[Zend Modules]
Zend Debugger

0
Comment actions Permalink

Hi Alexandr,

but I even do not see "In the PHP page that opens, choose Zend Debugger from the Debugger drop-down list.    

I would assume that this refers to PHP Interpreters settings page: http://www.jetbrains.com/phpstorm/webhelp/interpreters.html

I want to debug my script with zend debugger but I always get this notification "Connection with 'xdebug' was not established".

What scripts are you trying to debug -- CLI mode or web page?

If first (CLI) -- then the correct debugger must be set in PHP Interpreter settings (the aforementioned link -- Settings | PHP --> Interpreters (the "..." button) ).
If second (web page) then it can be configured at Settings | PHP | Servers

http://confluence.jetbrains.net/display/WI/Documentation -- if you follow "Zero-Configuration Debug" article, the PhpStorm will pick up correct debugger automatically (for web-page debug, obviously, as PHP Interpreter must be set before attempting debugging CLI script).

0
Comment actions Permalink

thanks
my fault, I completely forgot about this

0

Please sign in to leave a comment.