Speeding up PhpStorm 5 -- how to turn off some checking

I have a Symfony project loaded in the IDE, and it seems like I'm frequently waiting 5-6 seconds for the IDE to catch up with my typing.  This often happens when I have a typo, like closing a quote when I don't need to (since it automatically creates the closing quote).  

I assume it's looking through the class names or formatting or something, but I'm on a pretty fast machine and it's too slow sometimes.  

How can I turn off some features, or delay formatting, something like that, that would make sure that typing is really snappy.  I feel like when I make a mistake, I'm punished with being locked out of my keyboard for those few seconds.

Thx,

Tac

1 comment
Comment actions Permalink

Hi there,

Settings | Inspections -- that's the place for all "checking" -- will affect ALL files (unless you configure it for certain scopes only).

But first try "Code | Configure Current File Analysis..." (or the same by clicking on "inspector" guy in status bar) -- this will allow you to see if there are any improvements at all.

Other than that -- file new ticket directly to the Issue Tracker:

0

Please sign in to leave a comment.