Configuring code autocomplete

Is there any way to configure how PhpStorm completes certain bits of code? When I'm in a PHP doc I'd really like to be able to type in an opening quote mark without PS immediately adding another.

13 comments
Comment actions Permalink

Hi there,

You can turn this feature off, but it will have global effect: File | Settings | Editor | Smart Keys -> Insert pair quote

Right now there is no way of optionally turning such features ON/OFF (bu user, I mean) depending on where you currently have your cursor: php code or comment block.

0
Comment actions Permalink

Exellent, thanks Andriy, that's good enough for me.

0
Comment actions Permalink

Unchecking this seems not to work.
How can they do such things anyway so it is forced even OUTSIDE the editor ???
Unchecking it does not work in the editor, nor does it work outside the editor.

I get this mess globally on my complete computer now.... skype, messengers, emails
everywhere the frustrating automatic quote closing is used, so special chars like
for example on a us international keyboard we can use ' + e to get e with an accent,
also this is complete disabled by this mess.

So please fix this crap as this frustrates me BIG TIME.

0
Comment actions Permalink

Hi Patrick,

Why so mad?

Unchecking this seems not to work.
How can they do such things anyway so it is forced even OUTSIDE the editor ???
Unchecking it does not work in the editor, nor does it work outside the editor.

The settings works just fine in editor .. and it has no way of affecting anything outside of IDE.

First -- I would suggest disabling all 3rd party plugins in PhpStorm (in case it is one of them).
Second -- I suggest closing your other programms one by one until you find the one that messing things up.

0
Comment actions Permalink

No way we can interfere with otther software. Please look for some other tool that does that to your system.

0
Comment actions Permalink

There is no other tool doing this.
I have this problem since i installed phpstorm.
I really like the ide though, but i become so mad because it frustrates me big time.
As we use special chars a lot in The Netherlands, and that is now not possible anymore,
as that stupid thing always prints a double single quote :-(

Furthermore i use no extensions, just the normal phpstorm install.

0
Comment actions Permalink

If i uncheck it, it still uses the auto-completion in the editor and my entire pc.
You understand now why i get so mad ?

0
Comment actions Permalink

So you are saying that if you have PhpStorm pen it doubles the quote characters (regardless of the settings), but as soon as you close PhpStorm it starts working OK in other programs?

0
Comment actions Permalink

Nope, i am saying, since i installed phpstorm the repeating of the single quote or double quotes is system wide for my pc.
I uninstalled java 7 and javafx 2.1 to see if that solves it, but no it does not.

So even when i do not load phpstorm ide i have that issue everywhere, skype, notepad++, google talk, mainly ALL programs.

And it all started when i installed phpstorm.

In the beginning i liked it in the editor, but outside the editor it should stop doing that.
No matter if i check or uncheck, i always get the single quotes repeated (double quotes also btw)

0
Comment actions Permalink

That's definitely not a PhpStorm then -- especially since it happens when it is not even loaded. Most likely (IMHO, of course) just a coincidence .. or maybe you have keyboard issue (sticky key?).

1. There is nothing that got launched on startup or anything like that -- you can use PhpStorm by just downloading zip archive (so no installer) and it will work. Installer here is just a standard tool -- it does not make any system files or system settings modifications -- only uninstaller part and shortcuts.
2. Your system Java version does not make the difference here since PhpStorm for Windows comes with bundled Java (should be v1.6.31 -- check it at Help | About) unless you explicitly configured PhpStorm to use your own / custom Java installation.

If you want to try, you can un/reinstall PhpStorm, but I do not see how this may help since I do not see any relation with the problem:

  • back up your PhpStorm settings (on Windows 7 it would be C:\Users\USERNAME\.WebIde40)
  • uninstall PhpStorm
  • delete all settings (if you choose not to delete them during uninstall)
  • check if it's working properly now or not
  • reinstall PhpStorm


I would suggest googling for a program that can tell which key is processed by which program (on global level) -- I saw a reference to it somewhere on a Forum (search whole comunity, not just PhpStorm) or Issue Tracker, but I do not remember in what context or what was the name (it was like 3-5 months ago, I would say). It may help you finding the guilty program/module.

0
Comment actions Permalink

That is totally correct.
Thanks for thorough explanations, Andriy!

0
Comment actions Permalink

Besides that we are quite sure that's just impossible that we can be a reason to ANY system-wide problem,
we have hundreds of thousands of users around the world with all the configurations for many years - with zero reports of problems like that.
Seek other culprit.

0
Comment actions Permalink

After all the messages that i was the only one having this problems i decided to reinstall my windows completely.
And indeed, after a reinstall everything was ok again.
Sorry for the troubles.

0

Please sign in to leave a comment.