Unable to use debug with phpstorm 4 / xdebug trial mode before buying

Hello,
I plan to buy jetbrains phpstorm and I download and setup phpstorm4 RC3 on Windows 7 64 bits.
I like phpstorm and would like to buy it but I never can use Xdebug though I can use it with other PHP editors, eclipse, netbeans, and even phped !

I found some tutorials for zero config xdebug but nothings arrive.

Generally when I use a debug in my php ide, the browser is automatically launched when I click on debug button.
I creat a PHP RemoteDebug configuration, put the absolute path on the root of my source code and /home/...../public_html on my remote server containing Xdebug, put PHPSTOM as Ide Key (is it necessary I never had to put an Ide key on other PHP Ide as eclipse or netbeans)
When I select my remote config and click on debug button, nothings appears. If I click again it write Error running connectremote : handler with same session  id is already registered.

Have I forgot something ?

5 comments
Comment actions Permalink

Hello fabrice,

Please read the following tutorial about PHP debugging with PhpStorm - http://blog.jetbrains.com/webide/2011/03/configure-php-debugging-in-phpstorm-2-0/. Let me know if you still have any issues here.

Thank you for feedback!

0
Comment actions Permalink

Hi
I also had much problems getting xdebug to work, but finally got it working, it actually is really simple

In php.ini
add

[xdebug]
zend_extension = c:\php\ext\php_xdebug-2.1.2-5.3-vc9.dll
xdebug.remote_enable = On

(Obviously change the path for the extension to proper path)

in php storm go to settings->PHP->Debug
set debug port to 9000.
Check can accept external connections
For  now check the other 3 checkboxes just to make sure it is working. You  will want to uncheck all 3 of these once you confirm it is working

Then in PHPSTorm Click on red telephone looking thing that says Start Listen PHP Debug Connections.
It should then be green.




Then what I did is I use firefox and downloaded the addon easy xDebug 1.5.


I am not sure if this next part is needed or not but I did it anyways.. I dont think you need it because I didn't have it set before and it worked fine.
Run phpinfo(); then look for  the value xdebug.idekey. Copy the value it says under "Local Value"
In the firefox addon xdebug change the idekey to match what was under local value.


To debug... when your on a page you want to debug click the start xdebug session..

Alternatively, if you don't want to use the addon or not using firefox, you can append XDEBUG_SESSION_START to the query string.

It should now hit the proper breakpoints.

Thats it. for me it was that simple.
I  used to have problems too and had like 20 config options set in  php.ini, but then found out you really don't need them. You only need  them if you are developing on a different machine then your running the  site on.

Hope this helps you to get up and running

0
Comment actions Permalink

master_kaos,

Thanks for sharing!

0
Comment actions Permalink

fabrice,

Do you still have the issue?

Thanks for feedback!

0
Comment actions Permalink

still no solution.
I have already bought now phpstorm but cannot debug.
It's very difficult to setup a remote server debugging.
the configuration is OK with other products as eclipse.
So I'm very disapointed that only phpstorm, a COMMERCIAL product is so difficult to setup for debugging.

my dev computur is Windows 7 64.
I have already tried all the tutos but never can use it.

0

Please sign in to leave a comment.