file path on server - where could I change this for debugging?

Hello,
unfortunately in a new project I have a problem with the debugging.
I configured all the same things like in the other project, but there is a wrong path for the debugging:
The path in the popup (see attachment) is :"opt/local/var/db/pear/pear-ini.php" but should be :"/opt/local/www/testdrive/index.php".

I try to set all the settings like in the "working" project.
I changed the settings in Deployment and also in PHP>Server but nothing changed in the popUp at the beginning of the debugprocess.
"
Before I "accept" the wrong path, but then the debugger stops on the 3. Line of the pear-ini.php and when I clicked the "Resume Programm" there is no stop on the set debug-points.

Does someone know where I can set the "path on the server" in the settings, becuase the line in the popUp is not able to change?

There have to be a place because, when I start the debug-process in the "good-working-project" all things are right no stop in pear-ini.php.

Maybe someone had the same problem.
Would be nice to find the right solution.

cheers
Martin



Attachment(s):
Settings_ProjectSettings_PHP_Server.png
Settings_ProjectSettings_Deployment.png
popUp.png
4 comments
Comment actions Permalink

Hi there,

The path in the popup (see attachment) is :"opt/local/var/db/pear/pear-ini.php" but should be :"/opt/local/www/testdrive/index.php".

What that pear-ini.php file is? Sounds like it is auto prepended (check auto_prepend_file in php.ini .. or even Apache settings/.htaccess, since you can pass php configuration variables through those files -- if configured of course) ?


In any case:

  • Settings | PHP | Servers -- this is the place to setup your path mappings for the debugging (needed when using remote/virtual server .. or symbolic links are involved).
  • If you do not need to debug that file (and it is outside of your project -- e.g. auto prepended) then uncheck "Force break at the first line when a script is outside of project" option at Settings | PHP | Debug
1
Comment actions Permalink

Hi Andriy,
like alltime, the right answer at the right time:

Thank you!

It was the "auto_prepend_file". Somwhere in my "new Development System" created with macPort there is this other configuration setting. It was not in the php.ini. This was the problem with my checks before I wrote the question in this forum. I checked the php.ini content and was looking for this pear-ini.php-File and I forgot the check also the printOut from phpinfo().
Unfortunately, I couldn't find the file or the the maching line-code where macPort put the addition "into" the php.ini. But your tip :

uncheck "Force break at the first line when a script is outside of project" option at Settings | PHP | Debug

was the important first help to solve the problem. I had also to

uncheck "ath mappings"Settings | PHP | Servers


There was an "automatic" pathMapping created. With this, phpStorm never stopps on the debug-points, after I solve the first problem with the stop in the "wrong" pear-ini.php-File.

Unfortunately, the pear-ini.php File is there for nothing, yet. It has a wrong content. I post it to a macPort-Forum. The file pear-ini.php should only extend the php_include_path with the pear-path. But it point to a non-exist pear-directory.
Except this, I would like to include the pear-directory directly in the php.ini file not over the "auto_prepend_file"-way. So I would have less problem with phpStorm in future.

Maybe a macPort user knows the place for this change or at least the content from pear-ini.php will point to the right directory.

With your help, now I can debug the new project too. The second hint and all the other stuff is for users with the same problem....

Thank you very much
cheers
Martin

0
Comment actions Permalink

Hi Martin,

I would like to include the pear-directory directly in the php.ini file not over the "auto_prepend_file"-way. So I would have less problem with phpStorm in future.

You definitely need to look at include_path variable in php.ini. For example -- that's how I have it here on my Windows machine: include_path = ".;E:\Projects\php\PEAR"

It was the "auto_prepend_file". Somwhere in my "new Development System" created with macPort there is this other configuration setting. It was not in the php.ini. This was the problem with my checks before I wrote the question in this forum.

Check output of phpinfo() -- the "Scan this dir for additional .ini files" and "Additional .ini files parsed" may give you the locations (but not always, unfortunately -- see comments for first link). In any case -- check user_ini.filename in your php.ini for such possible additional ini files.


Also -- that file can be loaded in .htaccess file (if you are using it, of course). For example (general example):  

phpvalue include_path new/path
0
Comment actions Permalink

Wouw, I'm learning every day :^O.

Check output of phpinfo() -- the "Scan this dir for additional .ini files" and "Additional .ini files parsed" may give you the locations (but not always, unfortunately -- see comments for first link). In any case -- check user_ini.filename in your php.ini for such possible additional ini files.

"Scan this dir for additional .ini files" gave me the location. Really simply, if I would open my eyes. Thank you for your patience. So I could find the file:
/opt/local/var/db/php54/pear.ini.
The content is :

; Do not edit this file; it is automatically generated by MacPorts.
; Any changes you make will be lost if you upgrade or uninstall php54-pear-pear.
; To configure PHP, edit /opt/local/etc/php54-pear/php.ini.
auto_prepend_file = '/opt/local/var/db/php54/pear/pear-ini.php'


After a change in the last line to uncomment this, "auto_prepend_file" has a empty string in the output of phpinfo().
Realy simple if I would have known it before or try it before.

So I found the "guilty" file, and to be honest I found it before with spotlight. But I couldn't understand where the file will included. Now I know the php.ini-part
"Scan this dir for additional .ini files" with help of your links as starting point for research. And at the end I found the point where this php.ini-part was set:
There is : /opt/local/include/php54/php/main/build-defs.h and on the line #define CONFIGURE_COMMAND the content '--with-config-file-scan-dir=/opt/local/var/db/php54'.
So I know where the line is born. And how I can change it, if macPort will change something in the pear.ini File while I update it some day.

Thank you very much.
Martin

0

Please sign in to leave a comment.