Debug not hitting breakpoints, and just disconnecting.

I'm using phpstorm 3.03 Build #PS-111.344 and Zend Server 5.6.0

Using Zend Studio toolbar, I debug a page.  PhpStorm picks up the call and begins debugging.  I've set 4 or 5 breakpoints.  It stops at first line of execution.  I click "Resume program" to get to the first breakpoint, but Storm immeadiately shows "Disconnected" in the variables window and the session is over.  I can "step into" without a problem but the execution stack is so huge it would take me an hour to get to my breakpoint.  This worked a few days ago but stopped hitting breakpoints for some reason.  Any ideas?

7 comments
Comment actions Permalink

Hello, Jim

It seems that the issue is related to the path mappings. Could you please attach a screenshot of your path mappings configuration (See Project Settings | PHP | Servers)?

Thank you for feedback!

0
Comment actions Permalink

Thought I had the basic mappings correct.  I'm running local with no symlinks.  And since it wasn't working, I checked the "use path mappings" box and set some of the paths but no luck.  Thanks for your help.



Attachment(s):
mappings.png
0
Comment actions Permalink

just guessing, but did you check that the local files are all in sync with the server files?   If something was missing on the local sources that exists on the server on the way to the break points it feels like that could cause issues.

0
Comment actions Permalink

Ya.  All my development is being done locally.  No remote server that I'm interacting with. Thanks.

0
Comment actions Permalink

Jim,

Please disable 'Use path mappings' checkbox. Do you still have the issue?

Thank you for feedback!

0
Comment actions Permalink

I would like to bump this thread as opposed to making a new one as I have exactly the same issue. I think that I do need the path mappings because I build my PHP application to another directory. Do I need to map every single file for the debugger to work in this case or can I just point the top level directory to the equivalent top level directory where the application gets built?

Let me know if you need a screenshot of any settings.

0
Comment actions Permalink

check which version of xdebug you have installed on your server too.

My servers hard drive died last week and i had to do a re-install from scratch.  One thing i did differently was to install the php-xdebug package provided by ubuntu server and it installed 2.0.x

I was having the same trouble.  the debug points would stop but it felt like it would time out and then fall out of debugging mode.

I installed (updated, )  xdebug via the pear method outlined on the install page: http://www.xdebug.org/docs/install

# pecl install xdebug

It updated to 2.2.0 and now I have xdebug working smoothly again.

0

Please sign in to leave a comment.