Git VCS Push/Pull fails

Answered

Hi

I've for the first time set up Git for use with Bitbucket.

Set up my first repo on an existing PHP project successfully via my MAC terminal and did the first commit and push.

Also downloaded SourceTree and used that successfully.

When it comes ot PHPStorm though and I make a change in a file and then try a directory Commit and push it fails with push failed "fatal: The remote end hung up unexpectedly".

Not sure whats going on thats making it fail but the other programs work.

.ssh directory does exist with files in home/user directory

github_rsa
github_rsa.pub
known_hosts

Mac OS X Lion system.

TIA
John

5 comments
Comment actions Permalink

Hi all

Ok, managed to fix this, will list the method I used below for anyone else that has the same issue.

Still unsure why it worked for terminal pushes or sourcetree pushes though.

1. Opened terminal
2. Entered ssh directory (On Mac) through

cd ~/.ssh

3. Backed up the existing github keys
mkdir oldkeys
cp github* oldkeys

4. Deleted old keys

rm github*

5. Generated new keys

ssh-keygen -t -C "myemail@domain.com"
Enter Passphrase: ************
Enter same passphrase again: *************

6. Copied pub key to clipboard

pbcopy < id_rsa.pub

7. Placed this key into account on bitbucket

My test Commit + Push in Phpstrom now worked without issue.

0
Comment actions Permalink

Hello John,

Great that the problem has been solved.
The root cause of the issue is that PhpStorm currently understands only those SSH keys, that have names id_rsa and id_rsa.pub, and doesn't understand others.

0
Comment actions Permalink

Hi Kirill

Ok thanks. Will make sure that I stick to id-rsa from now.

Cheers
John

0
Comment actions Permalink

Hey there guys! im having issues here on this exact topic.

I installed PhpStorm 2016.1.2 on my freshly installed Fedora 23 (testing the distro, will keep it for at least 90 days before deciding to go any other flavor), I created my ssh keys, added them to both bitbucket and github no problem, from console they work perfectly, but for some reason, they just dont from PhpStorm 2016.1.2

im not sure whats going on, or why its happening, I've been googling without any luck.

pwd and ls on .ssh

any pointers as to whats wrong? and how could i solve it?

0
Comment actions Permalink

solved! didnt had my gpg signature yet, darn forgot to generate it. fixed.

1

Please sign in to leave a comment.