SASS Question

So I'm using SASS in my project, and there is this minor annoying thing that happens.  When I'm typing out a child selector, I get code completion for a particular style rule see screenshoot:
Screen Shot 2012-06-30 at 11.55.41 AM.png

That's fine, b/c of course a style rule is sometimes what you want.  The problem is when I hit space after the "li" it auto-completes.  Is there a way to turn off auto-completion in a SASS file of globally on space?

3 comments
Comment actions Permalink

Hi  Matthew,

Is there a way to turn off auto-completion in a SASS file of globally on space?

No.

Either use Esc to close completion popup in such case .. or do not use automatic popup (put bigger delay or invoke it manually (Ctrl+Space) when needed).

I think (although I may be wrong here) it's a known issue -- please check both Issue Trackers (for PhpStorm and RubyMine (since Ruby is home for SASS plugin)): http://youtrack.jetbrains.net/dashboard/WI  &  http://youtrack.jetbrains.net/dashboard/RUBY

0
Comment actions Permalink

Thanks very much.  I think turning off auto-completion and learning to use control + space when I need it will work well for me.

0
Comment actions Permalink

This bug is reported already : http://youtrack.jetbrains.com/issue/RUBY-11004
Feel free to vote for it.

0

Please sign in to leave a comment.