New Java update - PhPStorm won't launch

Hi,

this weekend there was a Java update, and now PHPStorm won't launch.

The error recieved is "The JVM found at {0] is damaged. Please reinstall or define EXE4J_JAVA_HOME to point to an installed 32-bit JDK or JRE."

I have a 64 bit OS and I've tried reinstalling Java, what's the next step? I'd really rather not reinstall PHPStorm as there is probably a godo 10+ hours of config in it :/

16 comments

I'm running Windows 7 Home Premium

0

I can also add that I've tried pointing the environment variable to the correct java installations for both 32 bit and 64 bit, but the error still persists. I've tried pointing it to top folder, /bin, /bin/java.exe, /bin/javaw.exe. After some 15 reboots I reckon I've tried every possible combination I can think of.

0

On all versions of Windows by default PhpStorm uses (and should use) built-in JRE and is unaffected by system JRE changes. Why did you try to alter this in the first place?

0

I have not touched the default PHPStorm JRE at all, it's still intact in the jre folder of the PHPStorm installation.

This error came after the newest Java update that the Java updater found this weekend, I have not touched or modified any files in the PHPStorm installation directory.

Is it possible that it became corrupt somehow, is there any way to "reinstall" the PHPStorm JRE without the rest of the program?

0

Apparentely programs that use their own JRE use the environment variable to search for a "global" java installation if their own fails, I could only find other programs such as Vuze with the same error and the solution there(to point it to java.exe) doesn't work with PHPStorm(edit: probably because it's asking for a 32 bit version on a 64 bit system?).

0

Not sure, and we haven't received any other reports about this problem yet so its may be something very specific to your system.

Please try running IDE via supplied batch file - this approach makes problem more traceable..

0

I have solved the problem.

I re-installed PHPStorm in a different directory and copied the "jre" folder to the other installations jre folder and it solved the problem.

I did talk to some people I used to work with, they too experience massive problems after the latest Java update, almost every program on their win 7 64bit desktops refuses to launch after the update.

I hope this topic helps anyone else experiencing this problem!

Thanks a lot for the support!

0

I'm getting a similar failure here on Mountain Lion DP, when I launch PhpStorm 4.0.2 I get a dialog with two buttons: Cancel, "Move to Trash"

“PhpStorm” is damaged and can’t be opened. You should move it to the Trash.

Safari downloaded this file on 16 June 2012 from www.jetbrains.com

I downloaded 4.0.2 again, and got same result when trying to launch the "newer" copy.

Using Apple's JVM:

java version "1.6.0_33"

Java(TM) SE Runtime Environment (build 1.6.0_33-b03-424-11M3720)

Java HotSpot(TM) 64-Bit Server VM (build 20.8-b03-424, mixed mode)


Any suggestions?
Thanks.



PS I "downgraded" to 4.0.1 and it launches without a problem on the same Mac (well the sandbox alert shows up, but after you click past that, PhpStorm launches)


Message was edited by: Richard Scorer

0

Hi Richard,

Please try re-downloading 4.0.2 in another browser or even better -- on another computer. Quite possible original attempt was incomplete (somehow: or server or connection issues) or file got corrupted during download.

Unfortunately there is no MD5/SHA/etc checksums publicly available to verify the integrity of download :(

0

Hi Andriy,

I tried using Chrome to download, and copied the DMG from my laptop where PhpStorm runs just fine.

In both cases, I got the same alert.

Seems like there's something in Storm 4.0.2 which OS X Mountain Lion doesn't agree with (yet)

Thanks,
Richard

0

Its new Apple security "feature" - we'll sign the future builds to avoid this.

0

Hi Alexey,

Thanks for the info.

Happy enough to run 4.0.1 for now, look forward to the shiny new signed version!!

Cheers,
Richard

0

Great! The EAP worked fine, thanks!

0

Please sign in to leave a comment.