[Solved] Unregistered git root detected on my home dir

I do not know wether this is a bug or not:

when I open a project in /home/<myuser>/somewhere/<myproject>, phpStorm report "Unregistered git root detected" about the directory /home/<myuser>.

The problem is that this directory is not a git root (there is a .git/ignore file that seems to confuse phpStorm…)

3 comments
Comment actions Permalink

Hello Matthieu,

PhpStorm identifies a Git root by the presence of .git directory (or .git file in the case of submodules), so it is the reason of the message displayed.
It doesn't look like a good idea to use .git directory without Git, but if you need this you can ignore VCS root errors by selecting the checkbox in Settings | Version Control.

0
Comment actions Permalink

Hello Kirill,

thanks for the advice. I used to group my application preferences by directory (ignore and config in .git, and so on), but I moved them and all is fine now :)

0
Comment actions Permalink

Hi Matthieu, Thanks for posting!  I had the same .git/ignore file and removing it allows me to use pycharm function for git.  I think it came in one of my earlier projects when I had not used all of the pycharm features and I might have told it to ignore when I linked the lib.

0

Please sign in to leave a comment.