debug toolWindow wont open.

up until about 15 minutes ago, I would refresh the page in the browser on my local server and if the green telephone was on these things would happen:
#1)  a popup would ask me to ACCEPT or IGNORE the incoming connection
#2) clicking ACCEPT would open the 'debug' tool window
#3) a blue line would appear in the editor at the first breakpoint.
#4) hitting F8 would walk me through the code until i hit F9 to let it play out.

Now what is happening:
#1 if the green telephone icon is on the browser does not progress.
#2 no popup appears
#3 no 'debug' tool window opens.
#4 F8 and F9 do nothing.
#4 it will stay like this until i uncheck the green telephone icon, then it will play out.

I've tried restarting PhpStorm, tried removing the default settings by removing any settings in "Run/Debug Configurations".

Im in the middle of debugging stuff so not being able to debug is annoying.

Any ideas what setting i need to change to get it working again?


--- edit ---
as soon as you ask, you find it.

The settings that needed to be removed were these:
TOOLS -> EDIT CONFIGURATIONS -> PHP HTTP REQUESTS -> on the right hand side, there is "Server: [dropdown box] [...]" click on the [...] to bring up the Servers list.  Then delete all the servers.  The popup box will appear again.

6 comments
Comment actions Permalink

Hello michael,

Sorry for the delay.

Do you still have the issue?

#1)  a popup would ask me to ACCEPT or IGNORE the incoming connection
#2) clicking ACCEPT would open the 'debug' tool window
#3) a blue line would appear in the editor at the first breakpoint.
#4) hitting F8 would walk me through the code until i hit F9 to let it play out.

Please note that the dialog about an incoming connection will appear only once - when PhpStorn receives debug connection from some server (under 'server' we mean a pair - hostname and port) the first time.

Thank you for feedback!

0
Comment actions Permalink

Thanks Nikolay,

I dont have this problem any more.

The issue was that the server default settings needed to be cleared.  Im not sure how they went wrong, probably me hitting a key combo un-intentionally.

an incoming connection will appear only once

it will appear only once each time a debugging phase is run.

I found a situation where it was getting annoying. (but not annoying enough to spend time on it.)

If you have 2 sites on the same server talking to each other via an API on one of the sites and you want to debug the client site in one instance of PhpStorm, then the debugger will ask you to ACCEPT / IGNORE the incoming connection from the API server each time.  Click IGNORE, refresh the page, Click IGNORE, refresh the page Click IGNORE.

IGNORE doesnt seam to get saved as a server setting.  There probably is a way, but i dont know how.  Not even a big issue though.  Its comforting to see that dialog so you know the debugger is working.

0
Comment actions Permalink

Hi, michael,

We have an option which might be helpful for you - 'Ignore external connections through unregistered server configurations'. When the option is enabled PhpStorm will accept connections only from servers which added in 'PHP' | 'Servers'.

ignore_external_connections.png

Thank you for feedback!

0
Comment actions Permalink

michael,

Have you tried the mentioned option?

Thank you for feedback!

0
Comment actions Permalink

Just tried it now.  Seams to work.

Things im hoping though, that it is on a per/project basis so that when i setup a new project on my local server and hit debug that the dialog will popup. (ill find that out soon enough.)

--
Just tested that and it does seam to be per/project.  Cool :)

Thanks Nikolay

0
Comment actions Permalink

michael,

Please note that you can set default value for this option in the template project settings.

Thank you for feedback!

0

Please sign in to leave a comment.