HTML5 support?

Take a look at the a this picture; header, aside, article - all html5 tags are generating warnings. I thought PHPStorm supprted HTML5? is there a setting someplace I missed?

Screen shot 2011-06-14 at 11.13.15 PM.png

4 comments
Comment actions Permalink

If your HTML file has no doctype, press Alt+Enter | Switch to HTML 5. Also you can change html language level in Settings | Resources | Default HTML language level

1
Comment actions Permalink

Hello method with ALT+ enter does not work (nothing happens), I want to use the HTML5 doctype without declaring an instance files in smarty (phpstorm 4.0.1)

0
Comment actions Permalink

Hi aurelien,

Settings | Schemas and DTDs | Default HTML language level

0

Please sign in to leave a comment.